summaryrefslogtreecommitdiff
path: root/dev-python/owslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-21 20:55:01 +0100
commiteb509e1a15f595f667e8d177ddb73311084af6c0 (patch)
treefbc083f793d438d54b7fb4ec3a7e0286701b81bb /dev-python/owslib
parenteedf7b9dec39b69b43f7b581da418d37428db449 (diff)
gentoo auto-resync : 21:05:2023 - 20:55:01
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/Manifest2
-rw-r--r--dev-python/owslib/owslib-0.29.2.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index c2aaf5e9f897..d2fca77eb020 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1,3 +1,5 @@
DIST OWSLib-0.29.1.gh.tar.gz 960582 BLAKE2B e88446a843113453b116016a4488e1738472b2ff8faf7f0b1647db061e2af4b15e7ca64fb92d3298a9c4e906f8230a03fea664df65113dedba901a75c074da2e SHA512 10fc2d75b60c6a388d4729011e3843d0943e6273c94d628b288c973304c01359d77a4856a7dc74ac28358f26cbe9ffe85a67921ef5eb62475d2143dd20c46e08
+DIST OWSLib-0.29.2.gh.tar.gz 953216 BLAKE2B 3c0204cd62fdf3fe36ca2051a83a00ad165e7f7682d850c3796877c83382f7a3c68d2c02f8dfaa90016909393a9bfd6f2415499f6096de9f4333102b20ccd932 SHA512 66c0c6b4bcae08f0acbf1d4ee4a0e5d2b33996ae0d088ddd01844f050da364c581f7ea2a46d48652b969c75e8b31caf4c721f497ea079fb779d670199dd56746
EBUILD owslib-0.29.1.ebuild 1435 BLAKE2B 28352a9f3093657280d223834206e90a8f889ea88c0d8e6ccf804e1ca45deb0c27f2300db6e17eaf70897a4e9ac38cb0a8349c4dd9539fe60da0081b7b4a8197 SHA512 f384cfe36ffaf181a1ec0bad7d076f403d91dc38d5d35e133551dc237f6f5a2d166570f9a1f7353a4069157d6dffa169421f006bcad358dd326f5b3bcdce8856
+EBUILD owslib-0.29.2.ebuild 1556 BLAKE2B 1836861f351c26e7dbb9c29a6f3cb09e01f7d4ded314d7f8f712a4b702ed9a1dadff744dfc6d837b3b3646dfe083534f192f519c1851b28e3e50211f3f4ce3f6 SHA512 45b07f3ec8147d54c181bdba7932c0f828126dc4c63d8d1f77459f4f13f77c7f661566cf99df15029b44c48069ab8d1ccd3ef5a81d3ed9616f4ed476e031f581
MISC metadata.xml 520 BLAKE2B 01705147ed084a8215d15016b6cc94b2fcdc926eff2755cf2d4c768197d0c39a30a8b0602d93bac7ec221e32c30b9280b37d5736f2f46342ad36e23c1b4a7c1c SHA512 c146cb483caacbde7966a95b899372261493543826cb20d638cd91e7cae245d60f1504bc53f485e35ca5d6c3f83780fc1da211c0838c604dafde27284dd8e40b
diff --git a/dev-python/owslib/owslib-0.29.2.ebuild b/dev-python/owslib/owslib-0.29.2.ebuild
new file mode 100644
index 000000000000..6b89ed5f6480
--- /dev/null
+++ b/dev-python/owslib/owslib-0.29.2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1
+
+MY_P=OWSLib-${PV}
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="
+ https://geopython.github.io/OWSLib/
+ https://github.com/geopython/owslib/
+ https://pypi.org/project/OWSLib/
+"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # connection errors
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_110
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_200
+ tests/test_ogcapi_records_pycsw.py::test_ogcapi_records_pycsw
+ tests/test_opensearch_pycsw.py::test_opensearch_creodias
+ tests/test_ows_interfaces.py::test_ows_interfaces_csw
+ tests/test_csw3_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw_skip_caps.py::test_csw_pycsw_skip_caps
+ # different output from remote service, sigh
+ tests/test_ogcapi_processes_pygeoapi.py::test_ogcapi_processes_pygeoapi
+)
+
+python_test() {
+ epytest -o addopts=
+}