summaryrefslogtreecommitdiff
path: root/dev-python/owslib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-13 11:43:14 +0100
commit128025db16ea525715d1f5170c635c4f42ce4881 (patch)
tree07a1048840d97aefa9778386f8a8abc27940c708 /dev-python/owslib
parent37cf2a8dbadd546a550aac7c8079c3f77427cb63 (diff)
gentoo auto-resync : 13:04:2023 - 11:43:14
Diffstat (limited to 'dev-python/owslib')
-rw-r--r--dev-python/owslib/Manifest2
-rw-r--r--dev-python/owslib/owslib-0.29.1.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/owslib/Manifest b/dev-python/owslib/Manifest
index cf8a5331adcd..04307c90beb0 100644
--- a/dev-python/owslib/Manifest
+++ b/dev-python/owslib/Manifest
@@ -1,5 +1,7 @@
DIST OWSLib-0.28.1.gh.tar.gz 950453 BLAKE2B 8210efdea8ac2536348659a1bed46b5eb1b4da5a8b77979cc11d23273b1f806bef21d007ddd8a6961c16e241c4f3e18c93054c8abaa89baf8b765c98d74605d0 SHA512 bd62a5e371e64e0e256cc83d2f044294c20965f6b107b0dd9074ac752971620f01af4c7fc9a82e43dc81e71a6a36696b75403012841c28925b017d9c47b2d4a5
DIST OWSLib-0.29.0.gh.tar.gz 960632 BLAKE2B 11fdf8a2c89f187afe9010ec35722ad48a3a06957233f50a82e53d9f359278e3a722e55352c5c5110fa93c59d03a7183354f891c1d8fc4527cf299edd4fcd474 SHA512 f0f657bb7ca36d7abcf8ce606806b18ea05b7161e7571cf7ac7142a2d0fc632bb3d530a38f70822e0791317b081fcc8a6680c2d4aa64130ca8fe353774b05a72
+DIST OWSLib-0.29.1.gh.tar.gz 960582 BLAKE2B e88446a843113453b116016a4488e1738472b2ff8faf7f0b1647db061e2af4b15e7ca64fb92d3298a9c4e906f8230a03fea664df65113dedba901a75c074da2e SHA512 10fc2d75b60c6a388d4729011e3843d0943e6273c94d628b288c973304c01359d77a4856a7dc74ac28358f26cbe9ffe85a67921ef5eb62475d2143dd20c46e08
EBUILD owslib-0.28.1.ebuild 1115 BLAKE2B a70b83401316aae5d86aa363bbc7da41ab3ea5a65a10c410399cf361899bb9961c1cfeb68c906b3dde7a99aafef7baa1798efd2a0511dafb8e3d0df6a18b3917 SHA512 6e69b0ac1b3c5f93df932a93b4f72e88ed2d5b5d20b255821b0da36b6627401df32144a63a86063c4ade26e5ed676adc2c54d83c0c0707ec32285c2dc6318a66
EBUILD owslib-0.29.0.ebuild 1292 BLAKE2B b7617e88d7336f7ace4111559c249aa47e78711ba6357fef58f9d84f6b9cc2e2a992d40c3e7baef827f50132b4b9f64d1ef039a9e4b82be55f655bf10a824eaa SHA512 005107140702553a001a423d2761c634d01ea4c962ffd3c792baf3ed418de1e1b330b437f4dfb4ea6ef70abeffa098b19bc58de54b254c8fc509bc9f6db2f980
+EBUILD owslib-0.29.1.ebuild 1436 BLAKE2B 7296f1b4a524d5756c1fd64f70f725f9db3642ca16bfcc37c2d7e3e80adad3a6958f386569fa7a939bf839afd4cabe217c8cb171cd9eca181223a41b4b766871 SHA512 d26440c82414cc885243c319e7a07311e60c9b4c7bb40886075dcdb8ade2c97dde1e512099db76becc17112c85c075f2d379dd73de5de4b012b50de6e14b8499
MISC metadata.xml 520 BLAKE2B 01705147ed084a8215d15016b6cc94b2fcdc926eff2755cf2d4c768197d0c39a30a8b0602d93bac7ec221e32c30b9280b37d5736f2f46342ad36e23c1b4a7c1c SHA512 c146cb483caacbde7966a95b899372261493543826cb20d638cd91e7cae245d60f1504bc53f485e35ca5d6c3f83780fc1da211c0838c604dafde27284dd8e40b
diff --git a/dev-python/owslib/owslib-0.29.1.ebuild b/dev-python/owslib/owslib-0.29.1.ebuild
new file mode 100644
index 000000000000..e671e3bfb813
--- /dev/null
+++ b/dev-python/owslib/owslib-0.29.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=OWSLib-${PV}
+DESCRIPTION="Library for client programming with Open Geospatial Consortium web service"
+HOMEPAGE="
+ https://geopython.github.io/OWSLib/
+ https://github.com/geopython/owslib/
+ https://pypi.org/project/OWSLib/
+"
+SRC_URI="
+ https://github.com/geopython/${PN}/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+RDEPEND="
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pillow[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # connection errors
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_110
+ tests/test_wfs_generic.py::test_xmlfilter_wfs_200
+ tests/test_ogcapi_records_pycsw.py::test_ogcapi_records_pycsw
+ tests/test_opensearch_pycsw.py::test_opensearch_creodias
+ tests/test_ows_interfaces.py::test_ows_interfaces_csw
+ tests/test_csw3_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw.py::test_csw_pycsw
+ tests/test_csw_pycsw_skip_caps.py::test_csw_pycsw_skip_caps
+)
+
+python_test() {
+ epytest -o addopts=
+}