summaryrefslogtreecommitdiff
path: root/dev-python/outputcheck
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/outputcheck
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/outputcheck')
-rw-r--r--dev-python/outputcheck/Manifest4
-rw-r--r--dev-python/outputcheck/files/outputcheck-0.4.2-Driver.patch11
-rw-r--r--dev-python/outputcheck/metadata.xml24
-rw-r--r--dev-python/outputcheck/outputcheck-0.4.2-r2.ebuild51
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/outputcheck/Manifest b/dev-python/outputcheck/Manifest
new file mode 100644
index 000000000000..bebbb32eb523
--- /dev/null
+++ b/dev-python/outputcheck/Manifest
@@ -0,0 +1,4 @@
+AUX outputcheck-0.4.2-Driver.patch 738 BLAKE2B 972452f782966bc0237c4bb134ecb31c4d6126e08fda3630899f51e7028120d8cc0a9a89a33018648369a84e64e335b6520bf4e220c0fcde5257ad90640deb12 SHA512 1d0a3b694261a3ffa3fc51add70c3f6a0888120da1ef5aa4b09c57777b4b9497cdb44c03e294018c3f4c70d35aed7050638bc77101aa3e99fd0367ee03358118
+DIST OutputCheck-0.4.2.gh.tar.gz 16436 BLAKE2B 8c1678746b9fc11cf7b554da83a2e5a51c7095931894a543340e905ccff1e7240f1bb8ec12d348af9662ce7e515d70d6e8a93d1e6ab15629545aa5019a7fe648 SHA512 0abd1ca69c4ef683cc455c222979b313ed8b4906725cc534b80906cc4fb9a0acad855d4a6c39aa4777bbdc35309857082197a0cacdc191e4afb8a8a9a4bb2bed
+EBUILD outputcheck-0.4.2-r2.ebuild 1080 BLAKE2B af177a4a04b39124581ff5d3f9ade3265234fc3a38c40f151c612f43c8bdac960e94ef669b5e15da144bf612366b73523318d6e4afc54783daa269d99c6bd122 SHA512 b82c3c65f43b69c8e85de9758dd9eabca1eb4209f3e9a0d53a7025f54fa07472d58ff07ac10929394866e3d5e5416f326b063f87d89de9488043ca7349597b10
+MISC metadata.xml 899 BLAKE2B fb3372208ef75e4cda72be765d15426707f4879f5ac55ac79adc6991dfc61d624e33b30f549d83877f02cb6aa9a3f1b64a9aff6eb922e8de5221036808ae14d2 SHA512 265f6dfca1e7b83a72a6b9edb4399e49bd91eb7273bcd3b2d92f32d647963bb05ae2408b011a397d26772b5016c6b40809afb56090c36b449c263a5fa5b3dd05
diff --git a/dev-python/outputcheck/files/outputcheck-0.4.2-Driver.patch b/dev-python/outputcheck/files/outputcheck-0.4.2-Driver.patch
new file mode 100644
index 000000000000..9812bd728e0c
--- /dev/null
+++ b/dev-python/outputcheck/files/outputcheck-0.4.2-Driver.patch
@@ -0,0 +1,11 @@
+--- a/OutputCheck/Driver.py
++++ b/OutputCheck/Driver.py
+@@ -34,7 +34,7 @@ ExitCode = enum('SUCCESS',
+
+ def main(args):
+ parser = argparse.ArgumentParser(description=__doc__)
+- parser.add_argument('check_file', type=argparse.FileType('rU'), help='File containing check commands')
++ parser.add_argument('check_file', type=argparse.FileType('r'), help='File containing check commands')
+ parser.add_argument('--file-to-check=', type=argparse.FileType('r'), default='-', help='File to check (default %(default)s)')
+ parser.add_argument('--check-prefix=', default='CHECK', help='Prefix to use from check_file')
+ parser.add_argument("-l","--log-level",type=str, default="INFO", choices=['debug','info','warning','error'])
diff --git a/dev-python/outputcheck/metadata.xml b/dev-python/outputcheck/metadata.xml
new file mode 100644
index 000000000000..0891dc52ae07
--- /dev/null
+++ b/dev-python/outputcheck/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ OutputCheck is a tool for checking the output of console programs that is
+ inspired by the FileCheck tool used by LLVM. It has its own small language
+ (Check Directives) for describing the expected output of a tool that is
+ considerably more convenient and more powerful than GNU grep.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/stp/OutputCheck/issues/</bugs-to>
+ <remote-id type="github">stp/OutputCheck</remote-id>
+ <remote-id type="pypi">OutputCheck</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/outputcheck/outputcheck-0.4.2-r2.ebuild b/dev-python/outputcheck/outputcheck-0.4.2-r2.ebuild
new file mode 100644
index 000000000000..9ba13e596a42
--- /dev/null
+++ b/dev-python/outputcheck/outputcheck-0.4.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=OutputCheck-${PV}
+DESCRIPTION="A tool for checking the output of console programs inspired by LLVM's FileCheck"
+HOMEPAGE="
+ https://github.com/stp/OutputCheck/
+ https://pypi.org/project/OutputCheck/
+"
+SRC_URI="
+ https://github.com/stp/OutputCheck/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-python/lit[${PYTHON_USEDEP}]
+ )
+"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}/${PN}-0.4.2-Driver.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # Remove bad tests.
+ rm "${S}/tests/invalid-regex-syntax.smt2" || die "failed to remove bad tests"
+
+ # Create RELEASE-VERSION file.
+ echo "${PV}" > "${S}/RELEASE-VERSION" || die "failed to write RELEASE-VERSION"
+}
+
+python_test() {
+ lit --verbose "${S}/tests" || die "running test with ${EPYTHON} failed"
+}