summaryrefslogtreecommitdiff
path: root/dev-python/outcome/outcome-1.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/outcome/outcome-1.1.0.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/outcome/outcome-1.1.0.ebuild')
-rw-r--r--dev-python/outcome/outcome-1.1.0.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-python/outcome/outcome-1.1.0.ebuild b/dev-python/outcome/outcome-1.1.0.ebuild
index 9f4c94e538b5..722e60e24ead 100644
--- a/dev-python/outcome/outcome-1.1.0.ebuild
+++ b/dev-python/outcome/outcome-1.1.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
inherit distutils-r1
@@ -18,12 +18,16 @@ LICENSE="|| ( Apache-2.0 MIT )"
SLOT="0"
KEYWORDS="amd64 arm arm64 hppa ~ia64 ppc ppc64 ~riscv sparc x86"
-RDEPEND="dev-python/attrs[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/attrs[${PYTHON_USEDEP}]
+"
-BDEPEND="test? (
- dev-python/async_generator[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
-)"
+BDEPEND="
+ test? (
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
distutils_enable_sphinx docs/source dev-python/sphinxcontrib-trio