summaryrefslogtreecommitdiff
path: root/dev-python/oslotest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
commitcd18653acd5ce929bb0ec77dde842439db6f060c (patch)
treeb30f926c55ca488ef161aeb8967b1bbc59b31147 /dev-python/oslotest
parentf29f0d7da5f422c5491502ea0684163fa4471e6b (diff)
gentoo auto-resync : 22:06:2023 - 19:22:34
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/Manifest2
-rw-r--r--dev-python/oslotest/files/oslotest-4.5.0-py3.12-fix.patch23
-rw-r--r--dev-python/oslotest/oslotest-4.5.0-r3.ebuild40
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
index 48764e2f0c72..aa78be33886e 100644
--- a/dev-python/oslotest/Manifest
+++ b/dev-python/oslotest/Manifest
@@ -1,3 +1,5 @@
+AUX oslotest-4.5.0-py3.12-fix.patch 884 BLAKE2B b96dd157301ef24bd0ed7915e773887051bb2465fe1526aa1265b96e5dbafc0f26f6339da7c30b4fc2ffc4b9dc238ee8e03e15717c0030ad0416af915ee76693 SHA512 65210bad8a7c059cbe6f47373655477f79ec64a3571e4b8aac6b668590e923b3bdb5313555289bfbcf2daf42c13fe30f5269b34bf3ad510a3d8b62751269e719
DIST oslotest-4.5.0.tar.gz 38233 BLAKE2B 73fbf056467c5d86c647b0ff49ce2e75654c8a2ffbcda78f8ea49edddb55a4c5e0f065c7a95291468b2d5d73ec5f5152d16a2129ab17fc5e6d457284e684ec31 SHA512 2dc0644365621fe271e09f2f7be631f697749c9d343f1ce9b635986df41ec5be8787350b3f2eb6b6501f4baac1ec597b2f0ecada7936db967075ebce837e1517
EBUILD oslotest-4.5.0-r2.ebuild 794 BLAKE2B 97b9ffdad2bab158a249082c0ed3b21768236f72838d6c79687310b020766c9dbbf52160c675deaed896764bc65e2589227e807a646c1ea379fec6e1dbc8162b SHA512 9329438bca5ea5e093f789c618167e2d6596129d1228304d6f4abee73dae9c5569202bb2b5dc9f3d3326c32dd5350274a53cc04907bf2f3922c17bbd1ea2ee35
+EBUILD oslotest-4.5.0-r3.ebuild 848 BLAKE2B 84fa9b92d2f180bcba92328039753096e75cf20386075333d36beb06010905d53eb74b8f8089e495e4a4bd4cb5387fbd8cb0d5a6144e82f5fdecc19aa1cad0a9 SHA512 aabe6415df5aa6654e82d516429032a4f4e0e04307007c88d9f95dc7acc2a2d04effb064dfa1bd08b67ce669228698c147af3c30091ee9183bb320fdfd55674b
MISC metadata.xml 935 BLAKE2B ec63aed42de004f150dad32092560db0c3e76297cffdd791fa4f717af68ed6e88ee012923e1a41583ae56568e9e7ce8dcefa58d38cc66f675d78d9bf6a17601d SHA512 b116d2489597a1088c189a0db83950551c2da239d7a27319b63f886b63deb047fc6ef1b021db8044b14420bddbd759856d655e7d114df11bd918c1263ec8a1ed
diff --git a/dev-python/oslotest/files/oslotest-4.5.0-py3.12-fix.patch b/dev-python/oslotest/files/oslotest-4.5.0-py3.12-fix.patch
new file mode 100644
index 000000000000..d9325741d5d6
--- /dev/null
+++ b/dev-python/oslotest/files/oslotest-4.5.0-py3.12-fix.patch
@@ -0,0 +1,23 @@
+Subject: [PATCH] Replace find_module function
+
+find_module function was deprecated in Python 3.4 [1] and later removed
+in Python 3.12 [2], the find_spec function should be used instead. This
+change is necessary for proper Python 3.12 support.
+
+[1] https://docs.python.org/3.4/library/importlib.html#importlib.abc.MetaPathFinder.find_module
+[2] https://github.com/python/cpython/issues/98040
+
+Upstream: https://review.opendev.org/c/openstack/oslotest/+/886646
+
+diff --git a/oslotest/modules.py b/oslotest/modules.py
+index f453b17..8fe04a2 100644
+--- a/oslotest/modules.py
++++ b/oslotest/modules.py
+@@ -45,6 +45,6 @@
+ def __init__(self, module):
+ self.module = module
+
+- def find_module(self, fullname, path):
++ def find_spec(self, fullname, path, target):
+ if fullname == self.module or fullname.startswith(self.module + '.'):
+ raise ImportError
diff --git a/dev-python/oslotest/oslotest-4.5.0-r3.ebuild b/dev-python/oslotest/oslotest-4.5.0-r3.ebuild
new file mode 100644
index 000000000000..cfdb86d58150
--- /dev/null
+++ b/dev-python/oslotest/oslotest-4.5.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="
+ https://opendev.org/openstack/oslotest/
+ https://github.com/openstack/oslotest/
+ https://pypi.org/project/oslotest/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ >=dev-python/pbr-1.8[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3.12-fix.patch"
+)
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ sed -i -e '/subunit/d' requirements.txt || die
+ distutils-r1_src_prepare
+}