summaryrefslogtreecommitdiff
path: root/dev-python/oslotest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oslotest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/Manifest3
-rw-r--r--dev-python/oslotest/metadata.xml25
-rw-r--r--dev-python/oslotest/oslotest-3.2.0.ebuild62
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-python/oslotest/Manifest b/dev-python/oslotest/Manifest
new file mode 100644
index 000000000000..391cf2f14ee2
--- /dev/null
+++ b/dev-python/oslotest/Manifest
@@ -0,0 +1,3 @@
+DIST oslotest-3.2.0.tar.gz 35445 BLAKE2B d33c70e760fc595586c2d7b0ce6ed1f63b73c89ba078f85b70d3b6b1af1c4d115e6eb7b431f9ef52abf50290eb47a1d3adb2d014c2ba5cf7b93ecf0e46401a26 SHA512 4513291e2bec939f9734255cb0fe3f85b9eb8a8cadce58873ad4e85365a0ec27bc2084085f5b95b681b5e811b62458e18fe63aff1e022b2d8ace0ca48bd6a527
+EBUILD oslotest-3.2.0.ebuild 1545 BLAKE2B 3ebc64d4e5e1b48255fdb0af3a1717d33debbfb8801d37ff489a66fe645f77d07efe3f4fc4364f7521656a53045960411ecdca73b19947642dbe1df451335d99 SHA512 b12cd416ff0037207de486be6502570c6b64bc187b85bf577977716b11ef1c103737a24863898192573f9fe3093e920ebb67202e94c09e370713094926650444
+MISC metadata.xml 828 BLAKE2B a328982018731cc93cda675447ce2ba308e9164e8762df10a267c6b82389a717f16b5ba6d9843503e12a458f3ad5a726ce648f80e9ff781aeb429bd9034632f6 SHA512 48a68782c8ef2a15db7c73f03dbd4670b8ca25a6cfcf0c15d4585a93a75cc4591fb6edb70f7176cd72c97d1205ef8e5e898eafa9fca41ed0b00023bff93f966d
diff --git a/dev-python/oslotest/metadata.xml b/dev-python/oslotest/metadata.xml
new file mode 100644
index 000000000000..666623fd6560
--- /dev/null
+++ b/dev-python/oslotest/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ OpenStack test framework and test fixtures
+ The oslotest package is cross-tested against its consuming projects to
+ ensure that no changes to the library break the tests in those other projects.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">oslotest</remote-id>
+ <remote-id type="launchpad">oslo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslotest/oslotest-3.2.0.ebuild b/dev-python/oslotest/oslotest-3.2.0.ebuild
new file mode 100644
index 000000000000..ead6a997fa61
--- /dev/null
+++ b/dev-python/oslotest/oslotest-3.2.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Oslo test framework"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.8[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-1.0.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mox3-0.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-client-config-1.28.0[${PYTHON_USEDEP}]
+"
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_sphinx -b man
+ fi
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ if use doc; then
+ doman doc/build/man/oslotest.1
+ fi
+
+ distutils-r1_python_install_all
+}