summaryrefslogtreecommitdiff
path: root/dev-python/oslo-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-22 19:22:34 +0100
commitcd18653acd5ce929bb0ec77dde842439db6f060c (patch)
treeb30f926c55ca488ef161aeb8967b1bbc59b31147 /dev-python/oslo-utils
parentf29f0d7da5f422c5491502ea0684163fa4471e6b (diff)
gentoo auto-resync : 22:06:2023 - 19:22:34
Diffstat (limited to 'dev-python/oslo-utils')
-rw-r--r--dev-python/oslo-utils/Manifest2
-rw-r--r--dev-python/oslo-utils/files/oslo-utils-6.1.0-py3.12-fix.patch26
-rw-r--r--dev-python/oslo-utils/oslo-utils-6.1.0-r1.ebuild60
3 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/oslo-utils/Manifest b/dev-python/oslo-utils/Manifest
index 915e8cddd3b4..9a64d84fe320 100644
--- a/dev-python/oslo-utils/Manifest
+++ b/dev-python/oslo-utils/Manifest
@@ -1,3 +1,5 @@
+AUX oslo-utils-6.1.0-py3.12-fix.patch 992 BLAKE2B 681d5a7a92e8aaf9003493dd282d36d6c87485d3bd7f16422eef4fa45395d52639a510c0d145f634b8fc68051c615211bcaaabdc77434053697b5c34eeee1cab SHA512 b5c59906ec5f3da5459a28dfce5cdc7c64cea5e6b9e0acb0e147a464aa76b4bbf924089c7ae4891ad473e82b75e30ba2281787f139752e389bf17663d6421e8c
DIST oslo.utils-6.1.0.tar.gz 102843 BLAKE2B 8bf3889bcf82fd12589c58b2020164f1183fa9ed19491a05d252a6157841651259e3b2f412affb5d53eff4bf7f21e34a4666fdb91106652a937c79b5fd9c1c14 SHA512 ae86fe4dfe2db25c682ee533a16830fc3e03eb408ae4acd832b6aded9d7d93fd91927444f054b594b4834e338c8f13c48d0c9796b224923adc1d0df7f6cfb84a
+EBUILD oslo-utils-6.1.0-r1.ebuild 1515 BLAKE2B 0e387de8a15fd60eea83975e9f0f38bf2efb9967a2af0c9a9bb28b33c7df203b887e49dfdc466bd48c148faa20d9eff9c97d5a7cd03aef113e688fe34ebda7fd SHA512 25f90e4306d2858fb6f4ba5a78b06163086ea6867b0b7ace0ce87969be6815b47bacbb19727887f0ebbd989e25d2ba91842d63eabadce775f0771b5ea8f4767d
EBUILD oslo-utils-6.1.0.ebuild 1461 BLAKE2B 53aa8978114b40a35970bcb891b66815734400a9d794046ed56591f71f01dbd68b22f73feb4b37ef9a93dad4a5e03422441987dc63d7cc70cacf725d5b7d25ac SHA512 4280d8f31efa15078727474af9219061cf1af3b5601998871fb664fd354716e76a9cbcfd9aa2fb3bda0261cec4aca3de1d65810611e8771f4364d7d53c818d89
MISC metadata.xml 667 BLAKE2B 2d3b1f3c01b74c3db8239b0711f6b10488cc17b214509a64607f3112e7100eb39f2d8774639d47a40cbad6786e7dee1430327a78b357b516325e5d06babcdee5 SHA512 e97a4a1f3718a69d39706d816f17018a7d57fd81702cd88ee01f9b849405f2f08769d381c5e41be84d8ae0c69a2a977b0dcb3ee1a481502ebf49f5ad6a5d6a95
diff --git a/dev-python/oslo-utils/files/oslo-utils-6.1.0-py3.12-fix.patch b/dev-python/oslo-utils/files/oslo-utils-6.1.0-py3.12-fix.patch
new file mode 100644
index 000000000000..8b92b6f41aa1
--- /dev/null
+++ b/dev-python/oslo-utils/files/oslo-utils-6.1.0-py3.12-fix.patch
@@ -0,0 +1,26 @@
+Subject: [PATCH] Replace deprecated assertAlmostEquals method
+
+The assertAlmostEquals method has been deprecated since Python 3.2 and
+was removed in Python 3.12 [1], assertAlmostEqual should be used as the
+replacement.
+
+[1] https://docs.python.org/3.13/whatsnew/3.12.html#removed
+
+Upstream: https://review.opendev.org/c/openstack/oslo.utils/+/886725
+
+diff --git a/oslo_utils/tests/test_timeutils.py b/oslo_utils/tests/test_timeutils.py
+index 98194f1..390d037 100644
+--- a/oslo_utils/tests/test_timeutils.py
++++ b/oslo_utils/tests/test_timeutils.py
+@@ -192,7 +192,7 @@ class TimeUtilsTest(test_base.BaseTestCase):
+ before = timeutils.utcnow()
+ after = before + datetime.timedelta(days=7, seconds=59,
+ microseconds=123456)
+- self.assertAlmostEquals(604859.123456,
++ self.assertAlmostEqual(604859.123456,
+ timeutils.delta_seconds(before, after))
+
+ def test_is_soon(self):
+--
+2.39.3
+
diff --git a/dev-python/oslo-utils/oslo-utils-6.1.0-r1.ebuild b/dev-python/oslo-utils/oslo-utils-6.1.0-r1.ebuild
new file mode 100644
index 000000000000..fdf5c1a7593c
--- /dev/null
+++ b/dev-python/oslo-utils/oslo-utils-6.1.0-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Utility library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.utils/
+ https://github.com/openstack/oslo.utils/
+ https://pypi.org/project/oslo.utils/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/netifaces-0.10.4[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.2.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/ddt-1.0.1[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-py3.12-fix.patch"
+)
+
+distutils_enable_tests unittest
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}"/install -name '*eventletutils*' -delete || die
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}