summaryrefslogtreecommitdiff
path: root/dev-python/oslo-serialization
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/oslo-serialization
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/oslo-serialization')
-rw-r--r--dev-python/oslo-serialization/Manifest2
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.24.0.ebuild74
2 files changed, 76 insertions, 0 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index 12b7d2547a8b..751a9c66ab29 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1,3 +1,5 @@
DIST oslo-serialization-2.20.2.tar.gz 29486 BLAKE2B 73fda86ced11c7c6dfb1a15c761645583cee463521285dc194cc1aebd5ef100832190bb0b07f825472286dab8ffc4dbed5cf6183fd86128bd74d51c5d15996a8 SHA512 1bcf50a090a0ec74d1aca7de6cc83f7451778eae7335427d11f732120ec99163441ee0bde13df6e660574c7ac5fcafe746cdbcb421e57f02d782f2405d5e33c7
+DIST oslo-serialization-2.24.0.tar.gz 28948 BLAKE2B 8e57d14b21deefd8058f4dd677493072b0bfdc08bfb18faae2f6a09c4ab4e29ce544e479427a6c6557e0ca78fd7b525aa6a8ab3443a01c3d856ee3556f5f3f5e SHA512 8c2103409d9ec2ebfd45eefb56ed42b1ca52c0f8eaf5deff1020a67f813c8524d1bffd81d97a1ad28c80b4a5afeaebca829c4580e635f514900fd0835782990c
EBUILD oslo-serialization-2.20.2.ebuild 2040 BLAKE2B 9d0d544c9bf305c8a6481dd9b376c69a90a94309b6739566ffa2fcb02a8d1ec5d50e83ae9bf5bbf7aba3f980f7652675cfd6c21c2d905b0263b166fd2bde4312 SHA512 770ba0ee01c2522ffdbc24e6df3f2b6c3325174cc529a54b8347cba53109712e2e4949a0e55f12babf5c9f5a0e142ffba7b18ef9cff47a791c417d2b1805162b
+EBUILD oslo-serialization-2.24.0.ebuild 1948 BLAKE2B 85a1c7e90c1b951c9943ee1ea0cecd24f340e214b1f78813f67d1959d101cff5ae1a1af0aa869b529c8c915b4429739529a5ee8e0c6978e8462d38653cd3603f SHA512 07d012e03348640b872bbf7695cdb5ffa05c8fe45eff8579a62cd4f4f98721c697253beaa7db6121d8eed7e1399cde96d46f1eca4fdf777e2afebbadfcbcc30e
MISC metadata.xml 481 BLAKE2B 90f53fcdeb1a61f964745333fd7edd154ee61b05382b6c0a1aa54e78d7486cdce6757fc54c01a1ba2c7d9362f0ddf1045bf77dcc76036b995b1e0f0ed8e9b7c7 SHA512 41eb0d120210769caf9bc59d2ca53d136ec6dafb8e4eeb0dff126eacee1029d49ce18d85b6b19749a590579f63ffffe4c9d69919443c59c36b133d60629a6815
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.24.0.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.24.0.ebuild
new file mode 100644
index 000000000000..ef5eba506886
--- /dev/null
+++ b/dev-python/oslo-serialization/oslo-serialization-2.24.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Serialization library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ virtual/python-ipaddress[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ use doc && esetup.py build_sphinx
+ distutils-r1_python_prepare_all
+}
+
+# Note: Tests fail due to requiring installation.
+#
+# Installation appears to fail due ot the use of namespace packages but root
+# cause was never truly established.
+RESTRICT="test"
+
+python_test() {
+ distutils_install_for_testing
+
+ PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
+
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}