summaryrefslogtreecommitdiff
path: root/dev-python/oslo-rootwrap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/oslo-rootwrap
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/oslo-rootwrap')
-rw-r--r--dev-python/oslo-rootwrap/Manifest4
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild4
-rw-r--r--dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild49
3 files changed, 54 insertions, 3 deletions
diff --git a/dev-python/oslo-rootwrap/Manifest b/dev-python/oslo-rootwrap/Manifest
index a00266eac3a2..14dbf83f6671 100644
--- a/dev-python/oslo-rootwrap/Manifest
+++ b/dev-python/oslo-rootwrap/Manifest
@@ -1,3 +1,5 @@
DIST oslo.rootwrap-5.13.0.tar.gz 43433 BLAKE2B 8d53587f63022255683d18b8ce22dca07a160d7692e9d2fcd5e6c466bb6969da11a9a1af4646809921724b9f1b63b2532728bd3ade82312354793b6b4d15f0d4 SHA512 ff716e1e5900f754617578eb8bf60c1d2794474706f22a0c619c94177602ed3c3acde42ad499a7a613f310d6dffe526339b5cd1c96ecc727dcc43e1a9afd606c
-EBUILD oslo-rootwrap-5.13.0.ebuild 1616 BLAKE2B a25585dca831c504dc21f48107d48245e16f79e965ce17e533cdcc18219d383046d67733811753551e4813630b3fc572ac8554bf2fd2804e7bd4665bbb1f0881 SHA512 042f7a216148ce36b0000c0bf2254f1aa255ebaa67ec0281114b82b94f0fb93f5b1d656ddeb1d6ff9be8a5934e28db44f5b43deb8feff3dee1ce46bad00ac56f
+DIST oslo.rootwrap-5.15.2.tar.gz 45566 BLAKE2B 1755a52d1e380a512c50f5314f7a4f249da9e62030abfef531bf973277a98f1f42f1c27a69a4e6e5cf64441e6a7263a3780355da4860461cfafed172ea087946 SHA512 9fc4c4678a25ebecb08026e71ef8da44bf1214f177d5330de8d68cfce8c3d85f4085a9e19f282bc8b498a36d8a7e384cde354a95619a800e3a68aba088df5aad
+EBUILD oslo-rootwrap-5.13.0.ebuild 1611 BLAKE2B 28edc79ae8377b85508ac41e65064aa428639f004f0e520bab2ff4aee377f95bfd32013c9b2904aa8d295ed2187f880adbf60a69adfb29732e314605b80b4234 SHA512 950fe54920dc7430b75f50146841486a6d88e5bb0a8b458977886a2d33fc193c1d5fc88fdc21ace475cd0c34c03ab4cd01fb15de6300163eb6e6e480da42b4d7
+EBUILD oslo-rootwrap-5.15.2.ebuild 1649 BLAKE2B af72c9448c077222e3c0a42aa9e420f59261eac03d638f96d69a79ba9abeda0b50001bb919290c2207990ba6a39aaf05c6b3158ba87c3eef5977630c71338c05 SHA512 32a78a330f40e24b374ff20db5dd7d2a853cde858fbd9fbc41eee5eb30e2623d16592837cbf5098ded6391aff6473cb3eb8ff2b573f34e760b9bec1f09aa7f8f
MISC metadata.xml 600 BLAKE2B 93dce16794b8495f34be98af703ca0ba06ff4a2e378805f7f3b08d4805f01ad015a1144124e1ad32eb63e6b5c9a9378aea30a4b82eeab54b1cb9dc95280fc6fd SHA512 ad1012d9f43875065679837f787f6a8087876d4ef1e56d24fcd2aa379c85e628848dcf5fa03e84e5929cdfabc4c1b6e2f7167ac0a508f7f26b6b533405932e10
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
index 48ee97f9e724..53124c52f487 100644
--- a/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.13.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
inherit distutils-r1
diff --git a/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild b/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild
new file mode 100644
index 000000000000..8a42d3739fae
--- /dev/null
+++ b/dev-python/oslo-rootwrap/oslo-rootwrap-5.15.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Allows fine filtering of shell commands to run as root from OpenStack services"
+HOMEPAGE="https://pypi.org/project/oslo.config/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.rootwrap/oslo.rootwrap-${PV}.tar.gz"
+S="${WORKDIR}/oslo.rootwrap-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/stestr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=">=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ sed -i 's/sbin\/ip/bin\/ip/g' tests/test_rootwrap.py
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}