summaryrefslogtreecommitdiff
path: root/dev-python/oslo-middleware
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-17 20:03:52 +0000
commit4935506e9a5cbfabd37c64093eac5f36c2ff0017 (patch)
treeaf9dd93ea349eacaf28286c7c45c7a083b0b7c31 /dev-python/oslo-middleware
parent434d713861b70f6c6563d6ee50a8e64f14c970d9 (diff)
gentoo resync : 17.02.2018
Diffstat (limited to 'dev-python/oslo-middleware')
-rw-r--r--dev-python/oslo-middleware/Manifest2
-rw-r--r--dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/oslo-middleware/Manifest b/dev-python/oslo-middleware/Manifest
index 2b6aa2faf512..06f926112b7d 100644
--- a/dev-python/oslo-middleware/Manifest
+++ b/dev-python/oslo-middleware/Manifest
@@ -1,3 +1,5 @@
DIST oslo.middleware-3.30.1.tar.gz 56811 BLAKE2B e32cfb91a813883b8f50aa72484f679758efe1f1a0faf9fb3df25c77bc3e0c53464bc77fad95482ec002ca013e17d6f20e4318cd46373decb6ce7ce28f933884 SHA512 ec70d1a5e932c8da7bc4febce8be6b63ec8fb581e2b30051ab655a2a98689467d8e824d073cd19c8dd320d02a975ce22845ca5ea73f1c4e3b5ac9f725452a9db
+DIST oslo.middleware-3.34.0.tar.gz 55582 BLAKE2B 0e1af09d016cd5b81c5e0e719d40665ce24e0caaf28a4aae0043f99eee4e74a36669fdaa39330d0ffa13b588892480ee5081e1ffa41b431687c85964c7f30460 SHA512 ba8b418eb11f25ca929db32eb0451fdba757197e1bdba90dd56665e08daaa6f0a4dc6cc07788db4f14ebf2625312d3db69b73acc5cb425fa9e35299f22b6d451
EBUILD oslo-middleware-3.30.1.ebuild 2265 BLAKE2B 9fec3d7aa36fdd950281046c661df5d1826763a49d3c08215a0dc45ba151b6f019440f689fa34acdff22a01311946aea09f916259dbea15fddb7583350c90e75 SHA512 d1809bdc071a0187b4177b3088605b3a7ca66c8b50c23dc0a4ff3eb5bca33b7e374b65e2d660ae99d9088597c4c397815ca484e356c0ae7947f787c2667d035a
+EBUILD oslo-middleware-3.34.0.ebuild 2189 BLAKE2B c46ca81aad3c0fab09c3a7717ddb02adedefb6a3b93c5ea95ac6bc7b625217dce9b9a89144233f1b226d965367e6b715c46c85b8c97d7ec3b9f697987c3361c8 SHA512 615235b3e93f9aba67b554f25dbcb2bf67f1c0eb163ba1d69e0709ad9f31759e650f468c90a9a536f7600d5fbb384ee73f2163977e6f68c4cf15b2fe7f0ee0a7
MISC metadata.xml 766 BLAKE2B 09e791c996ee3e46083287243f3180ad073f53611981ef527b166c7c251401b2a3c34b8c0db8142ad77b4d4a82b92e43696b36f5fe80f7077e92928d5a825930 SHA512 38381c4dd993470e01cb5d469f345880a730b9afb3536b467a6e86243174192db346dfad58282e17d1bc0bcfb33e08b0f1797577e938c982e633cec8719d468e
diff --git a/dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild b/dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild
new file mode 100644
index 000000000000..5d1d13467205
--- /dev/null
+++ b/dev-python/oslo-middleware/oslo-middleware-3.34.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="Components injected into wsgi pipelines to intercept request/response flows."
+HOMEPAGE="https://pypi.python.org/pypi/oslo.middleware"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.middleware/oslo.middleware-${PV}.tar.gz"
+S="${WORKDIR}/oslo.middleware-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-serialization-2.18.0[${PYTHON_USEDEP}]
+ !~dev-python/oslo-serialization-2.19.1[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/jinja-2.8[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.0[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.1[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.2[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.3[${PYTHON_USEDEP}]
+ !~dev-python/jinja-2.9.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-context-2.19.2[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.7.1[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/statsd-3.2.1[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests tests/ || die "test failed under ${EPYTHON}"
+}