summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
commitfa1962ff69701bd9c0f15fb225cdbfb487125e0e (patch)
tree85b35bd5a3c73ea562768237a25da176adef5744 /dev-python/oslo-i18n
parentbd8ca999980e9c0c9ae40a11789c858bb58769e3 (diff)
gentoo auto-resync : 15:07:2022 - 19:43:32
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest3
-rw-r--r--dev-python/oslo-i18n/files/oslo-i18n-5.1.0-fix-py3.11.patch23
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild6
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
index 35ebfcb8042f..73a5d57cb3db 100644
--- a/dev-python/oslo-i18n/Manifest
+++ b/dev-python/oslo-i18n/Manifest
@@ -1,3 +1,4 @@
+AUX oslo-i18n-5.1.0-fix-py3.11.patch 1196 BLAKE2B 08d78934986b45d23095e73cd1f465c371372de3fe3f2681bd087a00556fda60b719a40471638423df109be55929c34602bdc589c256421bc89d5c2a0dfcbcfd SHA512 214f367932692c4910b4285df1c05ceb7389bdbf9821e6287df33c9a07e81990a00ce9514e6b53e9f562ae3647aa198247808a2e10f1a746ebdeff169b6c4749
DIST oslo.i18n-5.1.0.tar.gz 47423 BLAKE2B 621ec835fc975978fe3da392edda66471cd85fcfbe5af8c7a1704d7422d8f52f3b61c97ac8cfbd2aca94f65c8428cc5f97b095bc116ece605a4dc325a4a0171e SHA512 b2243f22de3ef3e33609c5aff573c4448a42c74d75022e023bea97c5338608e3fcd9da92aa2d262051e6b2ccbd5a88cfb2c91da79b7e3f81420dc24117da9b1d
-EBUILD oslo-i18n-5.1.0-r1.ebuild 779 BLAKE2B ed2b212f63b8f5478c46ea993ce1ab947565e8c5271de47941478a55c8beecd79ce59e1e02a8baa6d2eb6d949a9270593b5c764281d9f052b9cec72d0e105e92 SHA512 3161cf874a33eeda145b1f208d57ede2f33056015f0874ac2f4e235e1c5c98b66242726487aebdf95fa93e358b86fb2861f63bf578894392e65ab5b946565497
+EBUILD oslo-i18n-5.1.0-r1.ebuild 836 BLAKE2B 88fd56e73b242397185b2c440df68fb27301352847977599320d71be5dfd869814dd9cdd0fe5bdcf3a3766aabc219dd06bfe1c4bb2c64bd376070f6898dc9cf7 SHA512 0a1c1d78fe431c95f8003ad877c43f0e1dc7782ae21b4f8957cef4f652bb9c5e3d8e54c9ca1a3c9c40b13c9489f52d29cc4ac5ff812dd02ec7790912fa06f098
MISC metadata.xml 665 BLAKE2B 8890b37ab4cb0fce66a2e6f8be6da304a0c28d75d203a4413d6c8062a984a52b4c6004145992d3e00dd156ffd64a2bbb6b75eba85954de9fabcd88d24e925cc6 SHA512 b4a5778815e857a638e0ca9c9d228e9c941f9b541d667c7e4fcf6ef4814c8b24cbf0c8d24317ffbc7e65e25326f5043a546f42b7982f355551d1b0d0351472b0
diff --git a/dev-python/oslo-i18n/files/oslo-i18n-5.1.0-fix-py3.11.patch b/dev-python/oslo-i18n/files/oslo-i18n-5.1.0-fix-py3.11.patch
new file mode 100644
index 000000000000..d684cf2ed294
--- /dev/null
+++ b/dev-python/oslo-i18n/files/oslo-i18n-5.1.0-fix-py3.11.patch
@@ -0,0 +1,23 @@
+On python 3.11, we have some more warnings (deprecation warnings),
+so the count is >=1
+
+--- a/oslo_i18n/tests/test_message.py
++++ b/oslo_i18n/tests/test_message.py
+@@ -386,7 +386,7 @@ class MessageTestCase(test_base.BaseTestCase):
+
+ self.assertEqual(default_translation, msg.translation('es'))
+
+- self.assertEqual(1, len(w))
++ self.assertLessEqual(1, len(w))
+ # Note(gibi): in python 3.4 str.__repr__ does not put the unicode
+ # marker 'u' in front of the string representations so the test
+ # removes that to have the same result in python 2.7 and 3.4
+@@ -394,7 +394,7 @@ class MessageTestCase(test_base.BaseTestCase):
+ "translated message A message in Spanish: %s %s "
+ "(Original: 'A message: %s'): "
+ "not enough arguments for format string",
+- str(w[0].message).replace("u'", "'"))
++ str(w[-1].message).replace("u'", "'"))
+
+ mock_log.debug.assert_called_with(('Failed to insert replacement '
+ 'values into translated message '
diff --git a/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild b/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild
index 7053c73f76d7..0dd4662cf5a3 100644
--- a/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild
+++ b/dev-python/oslo-i18n/oslo-i18n-5.1.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit distutils-r1
@@ -24,6 +24,10 @@ LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~riscv x86"
+PATCHES=(
+ "${FILESDIR}/${PN}-5.1.0-fix-py3.11.patch"
+)
+
RDEPEND="
>=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
"