summaryrefslogtreecommitdiff
path: root/dev-python/oslo-i18n
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oslo-i18n
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslo-i18n')
-rw-r--r--dev-python/oslo-i18n/Manifest3
-rw-r--r--dev-python/oslo-i18n/metadata.xml12
-rw-r--r--dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild68
3 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/oslo-i18n/Manifest b/dev-python/oslo-i18n/Manifest
new file mode 100644
index 000000000000..457acc69e218
--- /dev/null
+++ b/dev-python/oslo-i18n/Manifest
@@ -0,0 +1,3 @@
+DIST oslo-i18n-3.19.0.tar.gz 41888 BLAKE2B 651b6e1ee2d2d6c11bd1b86b78eadf70b33338f5495fb93d58747635961df20fbf74fb2a949ef81b82efce582410f05c88806e678f688bb686b500378c77ff6e SHA512 2c12fc5ec24fbebd2624b3bf9d3043a62da84304e73a995c49b395e792bd9bd7d38a13f5e3086abe59bbb9ef43729a47eaee78ea0701ed05c15f5070af232a69
+EBUILD oslo-i18n-3.19.0.ebuild 1755 BLAKE2B 4f8b1a1c4b99948448456b45bc63e9f6823edd414be0b1d6e065cc178f1d1438c3165be5c2458ddab2da0c55dc48a75891043a1f519fcf993283d1cb281fa060 SHA512 3e6edb9e5fe343cc91b29896fe14f1cd24a2d83e51984b2fee0941bf35b6fd9c4bc5b96d6fa3bc0054a1f68cc6269f53d121248adcc29a664c002ea011aee839
+MISC metadata.xml 365 BLAKE2B de17547743fb15cc3453fbff770a48a4f7d7222e6a5f437064eef2269ecbc0a8ba3723893d653074364afd320894fda16f4e2f70da3dc6f60bf5e2ac763d61d5 SHA512 c3f2d54fd641ba2c5f423e2d358ccd8001354a7a3dc405af89b781ed167340b8a1dc23b3c15e70d60b72ed2d35ced17f9d4e6c1442ba8b3f919ab1788b33db37
diff --git a/dev-python/oslo-i18n/metadata.xml b/dev-python/oslo-i18n/metadata.xml
new file mode 100644
index 000000000000..e141cde0e1c0
--- /dev/null
+++ b/dev-python/oslo-i18n/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">oslo.i18n</remote-id>
+ <remote-id type="launchpad">oslo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
new file mode 100644
index 000000000000..07468ede85f9
--- /dev/null
+++ b/dev-python/oslo-i18n/oslo-i18n-3.19.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo i18n library"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/Babel-2.3.4[${PYTHON_USEDEP}]
+ !~dev-python/Babel-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPYTHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}