summaryrefslogtreecommitdiff
path: root/dev-python/oslo-context
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/oslo-context
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslo-context')
-rw-r--r--dev-python/oslo-context/Manifest3
-rw-r--r--dev-python/oslo-context/metadata.xml18
-rw-r--r--dev-python/oslo-context/oslo-context-2.20.0.ebuild45
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-python/oslo-context/Manifest b/dev-python/oslo-context/Manifest
deleted file mode 100644
index 79efbca540ea..000000000000
--- a/dev-python/oslo-context/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST oslo.context-2.20.0.tar.gz 28203 BLAKE2B cbb3cb6f30b1b16011caa6fdec36c19aae571125b88f642bfc52c5a8a63a2b17eb308628d9a5f19b8a0c3bd28fb0db54e5485abd10c90c9495de05263ac25709 SHA512 ce7bd92c7e22e02e91bdc86e9b697f746233a41081b4f3ebb9fe30fec8000c69f732f55de0d333b349b8e01e638ddc835fd3cf0d8f7a11aa3454466a1e87ad08
-EBUILD oslo-context-2.20.0.ebuild 1210 BLAKE2B 870c16d4fa4236a4e53ba9e9d978d89ca75ab43a4a3486d2d667479e81364d04ed337196df8554527b62ee5f658f3df5b129b217ef8dabd4cebdc82f98a702f3 SHA512 d93cb0fa3a4c273b5ad199ded83c254318fca14d5335bebafca8578340cf6fe0eddc23bf5babb7814ab77f4fb9b2acf4926638095605beb872530cacef209339
-MISC metadata.xml 700 BLAKE2B d0e048afd7e2d85b6cbadc1927d2cf83469e0c8bf31d6aa6516e8d9f6af5d07e387c975c54c2bd877a22f2a964ab6b99d7f2c70130efcb80af68368d2f4c769c SHA512 2ff5f7f1e4a65feee089f19c189a30668f09000ffe03e852d084d65f4db245e94086dea053620cfbde5a793f3c1014f84e3e3e192deb5e16e94bd46017e88bcb
diff --git a/dev-python/oslo-context/metadata.xml b/dev-python/oslo-context/metadata.xml
deleted file mode 100644
index b621cf95e226..000000000000
--- a/dev-python/oslo-context/metadata.xml
+++ /dev/null
@@ -1,18 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person">
- <email>prometheanfire@gentoo.org</email>
- <name>Matthew Thode</name>
- </maintainer>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription lang="en">
- The Oslo context library has helpers to maintain useful information about a request context. The request context is usually populated in the WSGI pipeline and used by various modules such as logging
- </longdescription>
- <upstream>
- <remote-id type="pypi">oslo.context</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/oslo-context/oslo-context-2.20.0.ebuild b/dev-python/oslo-context/oslo-context-2.20.0.ebuild
deleted file mode 100644
index 5e4b1fba4338..000000000000
--- a/dev-python/oslo-context/oslo-context-2.20.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
-
-inherit distutils-r1
-
-DESCRIPTION="Helpers to maintain useful information about a request context"
-HOMEPAGE="https://pypi.org/project/oslo.context/"
-SRC_URI="mirror://pypi/${PN:0:1}/oslo.context/oslo.context-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
- !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
- >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
- )"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
-"
-
-S="${WORKDIR}/oslo.context-${PV}"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-# This time half the doc files are missing; Do you want them?
-python_test() {
- nosetests tests/ || die "test failed under ${EPYTHON}"
-}