summaryrefslogtreecommitdiff
path: root/dev-python/oslo-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/oslo-config
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest3
-rw-r--r--dev-python/oslo-config/metadata.xml20
-rw-r--r--dev-python/oslo-config/oslo-config-5.2.0.ebuild71
3 files changed, 94 insertions, 0 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
new file mode 100644
index 000000000000..fcc6ec068d89
--- /dev/null
+++ b/dev-python/oslo-config/Manifest
@@ -0,0 +1,3 @@
+DIST oslo-config-5.2.0.tar.gz 130627 BLAKE2B 7d5e78a7486ea5b24d9eaa488c70c3222da137d230912551e98fdd4a433b3979c2d8841aa4cff3d763ca356ea1f80f2cba13716569ee41e8ff7c4e6511a3d91e SHA512 fa3323926f7f7b1a79e4823dfc102027cb466728500980d9f079c2098c93006b4fdeebb2f09bda41512dc854f5dfe080b727fa2d63910e6fc609d69fab87596c
+EBUILD oslo-config-5.2.0.ebuild 2059 BLAKE2B 903926387ee247a3803ced58b569125876424f90990b28837e46cb970c795f7e3811940e34da3c80934c725fd64d5cb7a8bb4d7baae68ff9907c627158955d6e SHA512 558446547c9442ff2d42eb63ce2c69a10a8f54e30b1f4da36ea45bb20ff5b2b82361ec243d6393f2967c61f0a97a7e82e9eefc1db492d90e7c0ee0d5bad8add5
+MISC metadata.xml 670 BLAKE2B 5e3551e2fb4d57226dd82ad46f361f624d1b05ccdeffc1ce86a90692a385841ed26739a3ab01e72284fd6dc47a2607ee1bf30548a2b754944a9b975629fef261 SHA512 c09cd1761655f29d25e689ec95939fa59f4fb9a3fbd48509c0a65d2d289e073b3c60faa838e4075efafe32b2caf2b7fc3ae46af556cd50f66c37ac5ed8a1d52c
diff --git a/dev-python/oslo-config/metadata.xml b/dev-python/oslo-config/metadata.xml
new file mode 100644
index 000000000000..7248bf25a18a
--- /dev/null
+++ b/dev-python/oslo-config/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ The Oslo configuration API supports parsing command line arguments.
+ Oslo also supports .ini style configuration files.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">oslo.config</remote-id>
+ <remote-id type="launchpad">oslo</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/oslo-config/oslo-config-5.2.0.ebuild b/dev-python/oslo-config/oslo-config-5.2.0.ebuild
new file mode 100644
index 000000000000..66895c8aa974
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-5.2.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+MY_PN=${PN/-/.}
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.17.0[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ use doc && esetup.py build_sphinx
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
+
+ testr init || die "testr init failed under ${EPYTHON}"
+ testr run || die "testr run failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_python_install_all
+}