summaryrefslogtreecommitdiff
path: root/dev-python/oslo-config
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-28 12:00:19 +0100
commit7166f3a0a0b7886d340010458d0b130013cb9989 (patch)
tree3ff502007dde9dba943a004a3bf201ae4e0787bd /dev-python/oslo-config
parent345c02ca33341652116ddec6705530223af2de85 (diff)
gentoo auto-resync : 28:08:2024 - 12:00:19
Diffstat (limited to 'dev-python/oslo-config')
-rw-r--r--dev-python/oslo-config/Manifest3
-rw-r--r--dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch43
-rw-r--r--dev-python/oslo-config/oslo-config-9.6.0.ebuild63
3 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/oslo-config/Manifest b/dev-python/oslo-config/Manifest
index 3412cb6b9697..41b37eab61dc 100644
--- a/dev-python/oslo-config/Manifest
+++ b/dev-python/oslo-config/Manifest
@@ -1,3 +1,6 @@
+AUX oslo-config-9.6.0-py312.patch 1745 BLAKE2B e9a9317c9f5943019029b437912bd8fcfa8f3531c69d43cf9202e87a4e8b26a605426c2ac41c041a64efed669fbe898384ceb7670bbccaec607aba9ea386ccfc SHA512 89bb7225a394fc6d965921413bc9fed882df9a9616a9f98c762433f00e4301df339da0bc18107bbe8f0a7f54a998c82e9651d451d9cb5547b4d8c7ef781cf3ea
DIST oslo.config-9.5.0.tar.gz 161655 BLAKE2B 7844729658ddd13ff89b4c14983cfeeb3f6352f99a190058bd924592d9183459ea2da5caead7a77ed6c4a4e395aac2dd53f56847d81ce911ce76a04fa69f5b7d SHA512 517bb9fe416451eb791087216facd8643d77affb738aa2623817302dfc9dbd242d1aa2ba8c542fee437f91b2049129fa097fe37fec8c6a28e0092fc4d64c0c4f
+DIST oslo.config-9.6.0.tar.gz 164859 BLAKE2B 251e75d3ed919f2fce1efcd3aa5695da6e7911972ac89065813ef0c5b2b96fc02c436362875bf965b70e149d4436080ab23092f8f17568324e30eec7befe25cb SHA512 ebf31035bdf6f4ac8a9ce6bef14ca52fcad4418696520f0c199058211dbaa37723273a7c07eded03b139426392d7df6b192381af23e2324a92632029b1031292
EBUILD oslo-config-9.5.0.ebuild 1519 BLAKE2B 6dacd9508a5f491fee75c647b235f832316f8b608d1208769a034e54133125959c3f9ea77b4bd1a1359ead30a5e17c4135dc208bfc2ffb1b236d166fffa5b490 SHA512 0830f035e382525edfa1ab10684c50e487be80964672d51bb0da3833c2c86398bf9137f21e49304445a1984085d6d8590b0f8a08e4430fabae6672f9744d5b74
+EBUILD oslo-config-9.6.0.ebuild 1640 BLAKE2B 084bed4c4292172d42dd54ac9d3dcb41a1c9903107fe7683a4b388c31633d1f6ffa0af6d1027a039aee2119153379b016431934d6ee4b6adc00681616faf5462 SHA512 988a7ee9c283f031f3ffac16a6f55577c242b3746642be333c6f248fc4de509dbde75c8f5039435f026f2401ec7a3d28ccdbf544606a0e7e9d88e7398ed7ea6e
MISC metadata.xml 759 BLAKE2B 88d0bbdc03286429f96554d184f664fbbdb4e067ed137f95a96a573c09b4573de90e50b2d5875d627c8b9ed03a0aec7233bdc8684b721e16085157480568c330 SHA512 a29b5a534042e949f780cfb000bd9ce9cde81ae1c5e6b429bd7854598a2d0f0c8b5358dc645135ba9016065460ff5b858e48e02cdbd12ade2b1fea9d0b407410
diff --git a/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch b/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch
new file mode 100644
index 000000000000..f105b7719199
--- /dev/null
+++ b/dev-python/oslo-config/files/oslo-config-9.6.0-py312.patch
@@ -0,0 +1,43 @@
+From 972d304bb23baef538ce759004410a20d8109ccb Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Tue, 27 Aug 2024 15:54:45 +0200
+Subject: [PATCH] Fix test_sub_command_multiple on Python 3.12.5+
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Update the expectations in test_sub_command_multiple for different
+argparse error handling in Python 3.12.5 and newer. Previously,
+the 'cannot have multiple subparser arguments' error would be output
+to stderr and cause the parser to exit; now it raises an ArgumentError
+instead.
+
+Closes-Bug: 2074130
+Change-Id: I83de6b6943b14f1f6df86a55603e6867dce680d3
+Signed-off-by: Michał Górny <mgorny@gentoo.org>
+---
+ oslo_config/tests/test_cfg.py | 8 ++++++--
+ 1 file changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/oslo_config/tests/test_cfg.py b/oslo_config/tests/test_cfg.py
+index 1759ae7..383b70f 100644
+--- a/oslo_config/tests/test_cfg.py
++++ b/oslo_config/tests/test_cfg.py
+@@ -4385,8 +4385,12 @@ class SubCommandTestCase(BaseTestCase):
+ self.conf.register_cli_opt(cfg.SubCommandOpt('cmd1'))
+ self.conf.register_cli_opt(cfg.SubCommandOpt('cmd2'))
+ self.useFixture(fixtures.MonkeyPatch('sys.stderr', io.StringIO()))
+- self.assertRaises(SystemExit, self.conf, [])
+- self.assertIn('multiple', sys.stderr.getvalue())
++ if sys.version_info >= (3, 12, 5):
++ self.assertRaisesRegex(argparse.ArgumentError, 'multiple',
++ self.conf, [])
++ else:
++ self.assertRaises(SystemExit, self.conf, [])
++ self.assertIn('multiple', sys.stderr.getvalue())
+
+
+ class SetDefaultsTestCase(BaseTestCase):
+--
+2.46.0
+
diff --git a/dev-python/oslo-config/oslo-config-9.6.0.ebuild b/dev-python/oslo-config/oslo-config-9.6.0.ebuild
new file mode 100644
index 000000000000..764961e742d4
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-9.6.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Configuration API"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.config/
+ https://github.com/openstack/oslo.config/
+ https://pypi.org/project/oslo.config/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-1.3[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-log-3.36.0[${PYTHON_USEDEP}]
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-mock-1.5.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ local PATCHES=(
+ # https://review.opendev.org/c/openstack/oslo.config/+/927273
+ "${FILESDIR}/${P}-py312.patch"
+ )
+
+ # broken by some dep upgrade
+ sed -i -e '/DeprecationWarningTestsNoOsloLog/,$d' \
+ oslo_config/tests/test_cfg.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x COLUMNS=80
+ eunittest -b
+}