summaryrefslogtreecommitdiff
path: root/dev-python/oslo-config/oslo-config-8.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/oslo-config/oslo-config-8.0.3.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/oslo-config/oslo-config-8.0.3.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-8.0.3.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/oslo-config/oslo-config-8.0.3.ebuild b/dev-python/oslo-config/oslo-config-8.0.3.ebuild
deleted file mode 100644
index bb05b85eae23..000000000000
--- a/dev-python/oslo-config/oslo-config-8.0.3.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Configuration API"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-CDEPEND=">=dev-python/pbr-1.3[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/debtcollector-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.18[${PYTHON_USEDEP}]
- >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
- >=dev-python/rfc3986-1.2.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- sed -i '/^hacking/d' test-requirements.txt || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- rm -rf .testrepository || die "could not remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}