summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-26 23:40:45 +0000
commite53a98716127eb7be20f46713a7442d5b8820633 (patch)
tree65a649f66422bc6677cae851cf42a166e45d2ced /dev-python/oslo-concurrency
parentfab95e98818bada1626a7723a1348f4e920d25e0 (diff)
gentoo auto-resync : 26:02:2024 - 23:40:45
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-6.0.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 59cbed40c33e..e407d628d589 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,5 @@
DIST oslo.concurrency-5.3.0.tar.gz 60677 BLAKE2B 72af8a54bbea85e7564c5c04463e106e16ab1608f7ae8662b1e5db3cc07d07b0bd2531dedd9227d6823700c0e93e3c160afe7ddf27f6023715e62b787246fb64 SHA512 6f3adc558a7879ae05bfbfa30dfa4c687e5f1cd6385a6881b2e1647b116aab5816d1333b42bac0c8554685ea2ac3ee293d5b9dc836c214bb708e2d53a6971639
+DIST oslo.concurrency-6.0.0.tar.gz 60373 BLAKE2B 24002c424894826f86d9fa7601d107ab04159ace9388944b615d4c1e35f54d5d8438b1a5021a3c3b0ef755d9b92382b9804fe8f7a84075feb7d7d523a4d1cbe9 SHA512 6a706e0590f6e29ab560e4133ffdb8dbd6c2cb2dc7cd16acd803ca93800a38223f57eec8c79698c9fe5bf47b1cdcbb89e1a98d3ea36f03a9ccee9da9ab39a0d9
EBUILD oslo-concurrency-5.3.0.ebuild 1172 BLAKE2B d36371992aa0fe4cb341b78cfcf44fbb963ebb5ccb47fcb2bf5e2910162bd3292593d44add0fe9fcb3b8391ec8b701dce254f1f30219bcbb47e0e04d4b99d778 SHA512 ae9c9d5386d759a2957ee3ef4e60ed83b3efb08446898defb8f3767f03ee7654aef064c337f2376986280c58cd04829880f516fd3bb19ed96f5845f58ccf37f6
+EBUILD oslo-concurrency-6.0.0.ebuild 1175 BLAKE2B 44b0e9b7764432e69da65508d166473313034c5dcdd3646b19508eaf928923f8073f7e0e44f3b9375b71cc3379c64d2971a58150485a8a617aa740222dc8bca6 SHA512 da9aadeba50a9165fef5dea1fdab25305ac724374bf41cec30eb642698a0fb0f2c56ab257298ea3b835dc77f2b42e5c8dd3478a58c07f41b6a8b3c71fba45766
MISC metadata.xml 423 BLAKE2B 965b9f3a9b25cd0f93f13bc12af982b8435e946c1317b6c3a013d016ac6ac3df39f94e1a69f6ef28355459cc5d59fa32c2004727e6772696dab755aee6ad46f4 SHA512 ffc8e1547e6f8356071744a4cf2d5f88d02f2a34322857245c68057699f0b87ea351a7821682ab3d72b777260c8887524467a201fe931787fa1b2ad67eb022a3
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-6.0.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-6.0.0.ebuild
new file mode 100644
index 000000000000..8706152fbfa1
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-6.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/.}
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Oslo Concurrency library"
+HOMEPAGE="
+ https://opendev.org/openstack/oslo.concurrency/
+ https://github.com/openstack/oslo.concurrency/
+ https://pypi.org/project/oslo.concurrency/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails, then hangs
+ rm oslo_concurrency/tests/unit/test_lockutils_eventlet.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ cd "${BUILD_DIR}/install$(python_get_sitedir)" || die
+ eunittest
+}