summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-11 16:02:49 +0100
commit88ebe56470c37b02a044e1091cad6b2df0f3be8f (patch)
treed80b2d9337c01c4a0fe11a2ef9691fc3153ed6d3 /dev-python/oslo-concurrency
parent4645b6f17f0da81e9fe84081fb126a37102ba153 (diff)
gentoo resync : 11.05.2018
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 9a5940b81a0b..92c313fe3afd 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,5 +1,7 @@
DIST oslo.concurrency-3.21.1.tar.gz 48866 BLAKE2B b621548173e30e7a7f3683d1f5ef3821574e780d1df99c91d8bb77d4e3d3280da395066be7c9ec95b3d3e640da694aae81943e126c8c4e6cd5f18c2db99efba6 SHA512 6d165ebf952b29d96d2d1a8b938b2ef4746c77b99a62ca596ee93e6fb6d919f183eede380763b6167cb7d372e03803556715523b7a63ad1dbadff4eede7c0bcd
DIST oslo.concurrency-3.25.0.tar.gz 48736 BLAKE2B fe8506599d175d22c44fd52bb2c4e5f238687ba7eeb926d3f042be14e6ef8cecb3c13b010c1540c835d9bc7e587560ea391ea00b99f05553d6bfd46d2bbe3d9c SHA512 0273112cdc0a1de45ec231b672f2ed8f8fe5842dea756bc062a18247036b2fdbfbce392f3edbfbb871a2bda94412f6c82f3a634fd98a77c1df5a243babcbd4de
+DIST oslo.concurrency-3.25.1.tar.gz 49218 BLAKE2B 95fccb051ef782a0b6cd01801e9b44272a8b04ca52fd0f00f91a2aa3514885c302a3f251885f59c32303708c91331f3f59ee06ebdce4751d013559a0e7d19b16 SHA512 5c306e742c652d66209a3218ccdc1d1f957ec6fde0b0bcb9411a71e470e8c0402c4cc1a40a05094ce591942ed16b8e0a7b456d60a64e0299ef32a257b37c8388
EBUILD oslo-concurrency-3.21.1.ebuild 1949 BLAKE2B 20a0d072bbb70be623739fb50f27b9a99af0a1804510def71dd1cf4326911e260bbe597f342d8553131e58df41d9c39fa3c29e856d8093694c5e5e817787f4e0 SHA512 c02c7c184971e6fb8072529cc4b904654cb3362725aedd4da2616d80e9ab844076b77e930733f8c94d1c24d999f45de6253d8aafc1f4d0fbdd5311ace5afccd1
EBUILD oslo-concurrency-3.25.0.ebuild 1806 BLAKE2B ee6d7879914bdb38aaa0bd7c780e5e4e673d273a64d45209ddce3414fb9dc2517b42169e69e8fd6b931b988bb7fc7d4d7a7a11239b51619a2d29369c4643b67c SHA512 4b6182948b1e1aba8710e0c1a24087d60036e4d4e193193c53837b59efe2ddc8278ec14c6d432398e78ee24074ae8e8082944305af2cb9ca57381bc92cc703c9
+EBUILD oslo-concurrency-3.25.1.ebuild 1853 BLAKE2B 2dba6b4c1f0a518c06cf3b5cfb42ece9fa80a2a0e8f8549408e67ba7c5737257b734b2932b043023254d7165b22f8e58f0a208c4240d2f55fec8d45a67571a82 SHA512 aa15bb4a96f3bc5d7459c4c53989e24131a6dff6139808484d5187f3b070edefc187845d238f997150905fe911fdaa185105acfec9076a82a185030a71a2dcdd
MISC metadata.xml 665 BLAKE2B d648ddb783230e648e931b39640fbb9d8a68029ae87ebe48eec97e05cadafa39dde8999fd01f8fc6b05cbd8590150b1f1444263b654ab3bb4bd3cfd2baf3d13c SHA512 de8aa8ac698d88f71b8368334e2e9c5edbc559a612e8d92379400fb73d82e44f70b9e23726fef13414e36fc159f3a8bc41753c4c83daa4d31aadef942e9a484e
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild
new file mode 100644
index 000000000000..535a45b3c7a0
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-3.25.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ <dev-python/eventlet-0.21.0[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.1.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^futures/d' test-requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
+}