summaryrefslogtreecommitdiff
path: root/dev-python/oslo-concurrency
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-08 10:50:14 +0100
commit3f71901f8c228f4de570abed1831ce3ee425343e (patch)
treea2dcd300d05ef8a2ec275b44a92a9d85bd3baa24 /dev-python/oslo-concurrency
parent12bb627384ddfd47382b9f1b6464481a58d01ebb (diff)
gentoo resync 08.09.2018
Diffstat (limited to 'dev-python/oslo-concurrency')
-rw-r--r--dev-python/oslo-concurrency/Manifest2
-rw-r--r--dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/oslo-concurrency/Manifest b/dev-python/oslo-concurrency/Manifest
index 68597432ed71..4c7934f452ac 100644
--- a/dev-python/oslo-concurrency/Manifest
+++ b/dev-python/oslo-concurrency/Manifest
@@ -1,3 +1,5 @@
DIST oslo.concurrency-3.25.1.tar.gz 49218 BLAKE2B 95fccb051ef782a0b6cd01801e9b44272a8b04ca52fd0f00f91a2aa3514885c302a3f251885f59c32303708c91331f3f59ee06ebdce4751d013559a0e7d19b16 SHA512 5c306e742c652d66209a3218ccdc1d1f957ec6fde0b0bcb9411a71e470e8c0402c4cc1a40a05094ce591942ed16b8e0a7b456d60a64e0299ef32a257b37c8388
+DIST oslo.concurrency-3.27.0.tar.gz 49604 BLAKE2B 04a7ed66c6d7cf37014080113bd3782cf186f57f486d6834fd28f3d518141f8dcac6f5e67ffb5ef894bc6f5085a90aa41a041e35b72325c645f7567dd743a912 SHA512 fb2e1377a8bbad451ef0a2713dfbcd58ec06d455e97fc4d8acf8bfde8eb27d59826d68dd3411bd60b6d6b5e68ff629f0e6e4781b17dd4349bc5b87f17c8b9d52
EBUILD oslo-concurrency-3.25.1.ebuild 1851 BLAKE2B 82e97eaa58e8a776e95c5652d7a1c360c5bb6088eb22037ca88b502575bf54d105afbdeb2657dfd235f8ce47a726b01b931ea57ab5a3f3ec5ec895604b2797e9 SHA512 74a287f8ee7553ba191ccdec0b28bfe11e6fc319a00b260d1d6c2da9bd47cfcc9ee8e8790a206dba70f3e8360f8397aa01403810296b28e4fe51354ae93895d1
+EBUILD oslo-concurrency-3.27.0.ebuild 1851 BLAKE2B 144f3a345ab19bdf7aed2135c979a4b6f7d63fe730581195fa7cfd5ba96580d33243f2765598ec0ce08b09b4add98c18c07232994060837a84966c0481295a55 SHA512 89e493f27d7191247743d3fb3be5d6faa2c79e5d7139ed3ca49a787905ff8bb463eeededbe1b867d3ab66f9f0cd6758139a1c8633c65302f9b5a49af74ae46db
MISC metadata.xml 665 BLAKE2B d648ddb783230e648e931b39640fbb9d8a68029ae87ebe48eec97e05cadafa39dde8999fd01f8fc6b05cbd8590150b1f1444263b654ab3bb4bd3cfd2baf3d13c SHA512 de8aa8ac698d88f71b8368334e2e9c5edbc559a612e8d92379400fb73d82e44f70b9e23726fef13414e36fc159f3a8bc41753c4c83daa4d31aadef942e9a484e
diff --git a/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild b/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild
new file mode 100644
index 000000000000..3793ae785651
--- /dev/null
+++ b/dev-python/oslo-concurrency/oslo-concurrency-3.27.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
+
+inherit distutils-r1
+
+DESCRIPTION="library for running multi-thread, multi-process applications"
+HOMEPAGE="https://pypi.org/project/oslo.concurrency/"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.concurrency/oslo.concurrency-${PV}.tar.gz"
+S="${WORKDIR}/oslo.concurrency-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+
+CDPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}
+ test? (
+ >=dev-python/oslotest-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/coverage-4.0[${PYTHON_USEDEP}]
+ !~dev-python/coverage-4.4[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.6[${PYTHON_USEDEP}]
+ !~dev-python/sphinx-1.6.7[${PYTHON_USEDEP}]
+ >=dev-python/openstackdocstheme-1.18.1[${PYTHON_USEDEP}]
+ >=dev-python/reno-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.18.4[${PYTHON_USEDEP}]
+ !~dev-python/eventlet-0.20.1[${PYTHON_USEDEP}]
+ >=dev-python/bandit-1.1.0[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ ${CDEPEND}
+ virtual/python-enum34[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-5.2.0[${PYTHON_USEDEP}]
+ >=dev-python/oslo-i18n-3.15.3[${PYTHON_USEDEP}]
+ >=dev-python/oslo-utils-3.33.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/fasteners-0.7.0[${PYTHON_USEDEP}]
+"
+
+python_prepare_all() {
+ sed -i '/^futures/d' test-requirements.txt || die
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ nosetests ${PN/-/_}/tests/ || die "test failed under ${EPYTHON}"
+}