summaryrefslogtreecommitdiff
path: root/dev-python/os-traits
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-python/os-traits
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-python/os-traits')
-rw-r--r--dev-python/os-traits/Manifest4
-rw-r--r--dev-python/os-traits/os-traits-0.11.0.ebuild29
-rw-r--r--dev-python/os-traits/os-traits-0.5.0.ebuild4
3 files changed, 34 insertions, 3 deletions
diff --git a/dev-python/os-traits/Manifest b/dev-python/os-traits/Manifest
index 71bfc3df5f55..4ee8f7640650 100644
--- a/dev-python/os-traits/Manifest
+++ b/dev-python/os-traits/Manifest
@@ -1,3 +1,5 @@
+DIST os-traits-0.11.0.tar.gz 20362 BLAKE2B 843c1a874dc5e7ee5066263a7dfd9491157c692a5489e53f9467d85589ce25570995cb25715409a49d81400a39bbf4c5ba0e616706e7462c4497f3613dd95599 SHA512 570fdc23ab3ae1920cbe0520bf2c007bd10c8372d83bb129993324a9a6de4462a9b5a86b816295dde9039f55cb8f125cb38653b4bfdb29630577327ec47c7d0c
DIST os-traits-0.5.0.tar.gz 15775 BLAKE2B 288db72d500a3187a8520b9674982f3233f8644a537ec04971453ece394344b7310cbf133785dfee7122e1aeadebee7fd91d18f57a6ccecf0f176fd569b2bfae SHA512 2dd9019b13fc3394bf97fa9ff6c82d02d26dc6ca8ba8b32e619e9f88a9fdee0d3082e3818ca6a51eea9eb45997dfb48eee6976190b27dff6ab5b892747ce2a54
-EBUILD os-traits-0.5.0.ebuild 740 BLAKE2B f74a9ea086db339c804a591e883284fab12589b2e71ab6e18e5786bc7fd53566ebd42aaf0adc75d0dea5832674fb96c0f231ff7f614cbb6583043c33ab36a10b SHA512 cf0909a66344292194aca6294541d34a22cade5e718f688257a53eaa2274ec3af67880346cb93ac01921fe7d6b16c70684b3edf4dfe69baf8e519badb82f629f
+EBUILD os-traits-0.11.0.ebuild 739 BLAKE2B 24b04d0044e8ae9daa4e87040c6a2ccd757e0a0ae644cb6578d1011744d62eb6cbd2a4f55a0790d1ffc0a09d834ce5a15d6724f1abe3fbbd74a836aadf1457a4 SHA512 f5539868cf12391e8951ee01be9e8825f566623b65ee172d911b782225f11c12e0e36d84d0c9c77cab565e1dcdbdaec0067d3229494a327e679c0dd295646b7c
+EBUILD os-traits-0.5.0.ebuild 735 BLAKE2B b808414f5f8a7a92060aa785d347d5180e0b0c52dcb0bd01c85dabf15eeaaf64b78233420608233cd434f9c3299b52a95e121228c822abcadd0ede4cf7ee378f SHA512 f6bda726549e1a5fd4fa344c09c21612f0aefb920c5786018eddf78473c51fbbcdb6855f90417abc651c12c91bd71d559c9f0d81452d56ad41731cbc05c6e00e
MISC metadata.xml 385 BLAKE2B 2ba965a78d301c8f0b65378ff482552eba70236b457b96461367e0ffa5cbab79ddac2296cab4184803f7970e4162faa0ace82762ff356eef2e739625bfc99878 SHA512 9dc66a1191f15d9a8569e229a59164a7527c2ad27c06f67d89a9a25910bdaafe70f6c9269a2482d5770105ce58a64705dde15db56b34f2568add1800df0cc42d
diff --git a/dev-python/os-traits/os-traits-0.11.0.ebuild b/dev-python/os-traits/os-traits-0.11.0.ebuild
new file mode 100644
index 000000000000..3ba218ddd663
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.11.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/os-traits/os-traits-0.5.0.ebuild b/dev-python/os-traits/os-traits-0.5.0.ebuild
index 625f225d1de9..d24dc67f1665 100644
--- a/dev-python/os-traits/os-traits-0.5.0.ebuild
+++ b/dev-python/os-traits/os-traits-0.5.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
inherit distutils-r1