summaryrefslogtreecommitdiff
path: root/dev-python/os-traits
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/os-traits
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/os-traits')
-rw-r--r--dev-python/os-traits/Manifest5
-rw-r--r--dev-python/os-traits/metadata.xml12
-rw-r--r--dev-python/os-traits/os-traits-0.3.3.ebuild29
-rw-r--r--dev-python/os-traits/os-traits-0.5.0.ebuild29
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/os-traits/Manifest b/dev-python/os-traits/Manifest
new file mode 100644
index 000000000000..d20fcbf10a6d
--- /dev/null
+++ b/dev-python/os-traits/Manifest
@@ -0,0 +1,5 @@
+DIST os-traits-0.3.3.tar.gz 17374 BLAKE2B cc5707317448f66aac84e69340dc1923436846553b059753217ae51971289dc2413ce858f46fc809e80b1754c917fd431b4134b3886eaa6ffac81a4962c30730 SHA512 bd8a7a29170aee1be59ed21684ed2a5dbb1440841a54b522bd3ec31ef61c9fd4f6eecca812c8a8b927c285142801c3da190d7bb47c7b315312e10c1c81d50e27
+DIST os-traits-0.5.0.tar.gz 15775 BLAKE2B 288db72d500a3187a8520b9674982f3233f8644a537ec04971453ece394344b7310cbf133785dfee7122e1aeadebee7fd91d18f57a6ccecf0f176fd569b2bfae SHA512 2dd9019b13fc3394bf97fa9ff6c82d02d26dc6ca8ba8b32e619e9f88a9fdee0d3082e3818ca6a51eea9eb45997dfb48eee6976190b27dff6ab5b892747ce2a54
+EBUILD os-traits-0.3.3.ebuild 743 BLAKE2B 8477c162056c97ee2d1fbde0bfb05256ac0df176d3f5bbb934a464d91aa0bb4270828b7e33b2c0c382c8a973d09986adfc4ac83a88210c219ade4c1057068561 SHA512 d8e2e9af800940e588c4f14e9bc47d65a4ce3370802de0eec9743f12e54f4848741e87086d783b492fc8419e862d8e879fb85640fc34f343bcd0c7d8beb2e5ad
+EBUILD os-traits-0.5.0.ebuild 740 BLAKE2B f74a9ea086db339c804a591e883284fab12589b2e71ab6e18e5786bc7fd53566ebd42aaf0adc75d0dea5832674fb96c0f231ff7f614cbb6583043c33ab36a10b SHA512 cf0909a66344292194aca6294541d34a22cade5e718f688257a53eaa2274ec3af67880346cb93ac01921fe7d6b16c70684b3edf4dfe69baf8e519badb82f629f
+MISC metadata.xml 385 BLAKE2B 2ba965a78d301c8f0b65378ff482552eba70236b457b96461367e0ffa5cbab79ddac2296cab4184803f7970e4162faa0ace82762ff356eef2e739625bfc99878 SHA512 9dc66a1191f15d9a8569e229a59164a7527c2ad27c06f67d89a9a25910bdaafe70f6c9269a2482d5770105ce58a64705dde15db56b34f2568add1800df0cc42d
diff --git a/dev-python/os-traits/metadata.xml b/dev-python/os-traits/metadata.xml
new file mode 100644
index 000000000000..6e876e03707b
--- /dev/null
+++ b/dev-python/os-traits/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openstack/os-traits</remote-id>
+ <remote-id type="pypi">os-traits</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-traits/os-traits-0.3.3.ebuild b/dev-python/os-traits/os-traits-0.3.3.ebuild
new file mode 100644
index 000000000000..3b5b610f897d
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}
diff --git a/dev-python/os-traits/os-traits-0.5.0.ebuild b/dev-python/os-traits/os-traits-0.5.0.ebuild
new file mode 100644
index 000000000000..625f225d1de9
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.5.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}