summaryrefslogtreecommitdiff
path: root/dev-python/os-traits
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/os-traits
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/os-traits')
-rw-r--r--dev-python/os-traits/Manifest3
-rw-r--r--dev-python/os-traits/metadata.xml12
-rw-r--r--dev-python/os-traits/os-traits-0.3.3.ebuild29
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/os-traits/Manifest b/dev-python/os-traits/Manifest
new file mode 100644
index 000000000000..650d73b0ec32
--- /dev/null
+++ b/dev-python/os-traits/Manifest
@@ -0,0 +1,3 @@
+DIST os-traits-0.3.3.tar.gz 17374 SHA256 130da3936873ded6d607e2cca85c12d603ad0971ace9d8c72fbf7fea67027edf SHA512 bd8a7a29170aee1be59ed21684ed2a5dbb1440841a54b522bd3ec31ef61c9fd4f6eecca812c8a8b927c285142801c3da190d7bb47c7b315312e10c1c81d50e27 WHIRLPOOL 31cbb9a40350d259988269ee9d80c8da826ac02a2d119dd514d7258a284963b5ee505969e04c2b3af41b737f79cd3edf53cdfbbdd563474b2ad39ccccfe3015c
+EBUILD os-traits-0.3.3.ebuild 743 SHA256 28173911f41303ff237f3bdd3ab489a37dd6280fbedc458231b243264f969d07 SHA512 d8e2e9af800940e588c4f14e9bc47d65a4ce3370802de0eec9743f12e54f4848741e87086d783b492fc8419e862d8e879fb85640fc34f343bcd0c7d8beb2e5ad WHIRLPOOL 2ed1e6bc1633ba36c9944eb0fc4daa5be2603e6205dbebc2ce89f44896d6ad258714c711d8fce3eedda96e9e25b05bcd5de7556458ea427bf7d403e31741e7eb
+MISC metadata.xml 385 SHA256 c9d51a5389c56f4def30dac2ad94755f3ee07d774d9c91a34fdba466430e4863 SHA512 9dc66a1191f15d9a8569e229a59164a7527c2ad27c06f67d89a9a25910bdaafe70f6c9269a2482d5770105ce58a64705dde15db56b34f2568add1800df0cc42d WHIRLPOOL 61389c4162f46fb33e45d8e9da637df5463f1bef56087bc2348d8db34da815e1a4f3a83de9c12faece3761d6dcf450a0644c17757826040896aa4bed362e494e
diff --git a/dev-python/os-traits/metadata.xml b/dev-python/os-traits/metadata.xml
new file mode 100644
index 000000000000..6e876e03707b
--- /dev/null
+++ b/dev-python/os-traits/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">openstack/os-traits</remote-id>
+ <remote-id type="pypi">os-traits</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/os-traits/os-traits-0.3.3.ebuild b/dev-python/os-traits/os-traits-0.3.3.ebuild
new file mode 100644
index 000000000000..3b5b610f897d
--- /dev/null
+++ b/dev-python/os-traits/os-traits-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="os-traits is a library containing standardized trait strings."
+HOMEPAGE="https://github.com/openstack/os-traits"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -i '/^hacking/d' test-requirements.txt || die
+ distutils-r1_python_prepare_all
+}