summaryrefslogtreecommitdiff
path: root/dev-python/orjson/orjson-3.9.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-24 20:44:11 +0100
commit342922f04a58a969ff23806acc427c7ff79119ce (patch)
tree7c491f1183b65ff952aefc31909ea49a54196be0 /dev-python/orjson/orjson-3.9.9.ebuild
parent27f59f8e16510831cc751de1406f71afbf464653 (diff)
gentoo auto-resync : 24:10:2023 - 20:44:11
Diffstat (limited to 'dev-python/orjson/orjson-3.9.9.ebuild')
-rw-r--r--dev-python/orjson/orjson-3.9.9.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/dev-python/orjson/orjson-3.9.9.ebuild b/dev-python/orjson/orjson-3.9.9.ebuild
index 2923b6b57190..93e76a4b5dc5 100644
--- a/dev-python/orjson/orjson-3.9.9.ebuild
+++ b/dev-python/orjson/orjson-3.9.9.ebuild
@@ -1,13 +1,11 @@
# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Autogenerated by pycargoebuild 0.6.1
-
EAPI=8
DISTUTILS_EXT=1
DISTUTILS_USE_PEP517=maturin
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
CRATES="
ahash@0.8.3
@@ -83,3 +81,8 @@ BDEPEND="
QA_FLAGS_IGNORED=".*"
distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -s
+}