summaryrefslogtreecommitdiff
path: root/dev-python/opensearch-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-21 21:44:48 +0100
commitd51fe7680c5270ddf8d324bbe11caab6d1e27ade (patch)
treea895b5889d79dbbb9aa52995fcac4816acfa07c1 /dev-python/opensearch-py
parent7d52991b5dce3a07be15d3cbbf06abb3fc08cb9c (diff)
gentoo auto-resync : 21:08:2023 - 21:44:47
Diffstat (limited to 'dev-python/opensearch-py')
-rw-r--r--dev-python/opensearch-py/Manifest5
-rw-r--r--dev-python/opensearch-py/metadata.xml13
-rw-r--r--dev-python/opensearch-py/opensearch-py-1.1.0.ebuild41
-rw-r--r--dev-python/opensearch-py/opensearch-py-2.3.0.ebuild45
4 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/opensearch-py/Manifest b/dev-python/opensearch-py/Manifest
new file mode 100644
index 000000000000..8fd3793947ae
--- /dev/null
+++ b/dev-python/opensearch-py/Manifest
@@ -0,0 +1,5 @@
+DIST opensearch-py-1.1.0.gh.tar.gz 204905 BLAKE2B d54875ddf57de0338c233abc69fed0df83154977b641f151c268faebfe303d851664abafab40bbf53fd5b24350f4136959130c1cc3be7ea92b616568d10130c8 SHA512 4eb3bc9e981c5293e68496143900bd50d7c3e301c76b080799bd08e5b840a2ec5610c5374f07c5a1f1e91cf3e709647f9585606ac1149fbf464cbe4168516b41
+DIST opensearch-py-2.3.0.gh.tar.gz 392631 BLAKE2B b2e88c98676c8c035f8c295b12b8cd8a7b8f4d6e4b1b4dca76f2417cf9d8c01b16bc36b3bed7f64d91d643aa2ceba681af6eac9b4d1a3d3bfa1a2cb13a53f167 SHA512 8be82ff19b4aa3d44dba8dd3b56676241de1999d6ae91c8414528132a6ed450850bf3b544a858c9fe0a5b188cd0da1196a524f9515e90369f5232c3ca7244d22
+EBUILD opensearch-py-1.1.0.ebuild 906 BLAKE2B d2f495b1b10f19841b9df213ec07385b56e1f6d45a6768d97a185c0292810dff2e19f4d29df1f31378d04331fc5b41c8626fb78314710f27a0f3138424a9820e SHA512 e4d20bab99ebe439bd712704237f7329492a14edb05e95054ce63d4e087b779dd047a4d45b2ad687405e4b62e4b176f7956b8de04be3d2fc8f23d7ec1f9ce921
+EBUILD opensearch-py-2.3.0.ebuild 1071 BLAKE2B 93d391b5d41a23c4fc03e74beddf4cd79443273dbfec7e440ff0741ada1fd6c342a4a6eb353c9ca7f8f41266f86dff0c37d7b648e152caf5d92f6401ad06b79e SHA512 60d0e13fcdae4d284ed6f0680789e99dc045e2b9853f8b9ca24edd6d3f9b20e6dc1c001c2f39f8bd48f458a1da1f25a46b5a2ba2419c85ba1a4b3e9c91a917da
+MISC metadata.xml 423 BLAKE2B 106c69949c360ff2fd43eb7fefc3999d12b00bf265e8852f24f659aad2977a8ef9e9504a0db493da3a3be16ca3b633b756dfa135b211a357cf8aaaa90f1ad0cf SHA512 3841e3efdbb8ba6d3a35797d211e2f946a9ca9f72862f439e3179fbfc02f7be414d8708581c6f439ad5684106c8feb74c716ad53186a71630ed274db9b85f241
diff --git a/dev-python/opensearch-py/metadata.xml b/dev-python/opensearch-py/metadata.xml
new file mode 100644
index 000000000000..76b4ac2da973
--- /dev/null
+++ b/dev-python/opensearch-py/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">opensearch-py</remote-id>
+ <remote-id type="github">opensearch-project/opensearch-py</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
new file mode 100644
index 000000000000..e8a8167526a5
--- /dev/null
+++ b/dev-python/opensearch-py/opensearch-py-1.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for OpenSearch"
+HOMEPAGE="
+ https://pypi.org/project/opensearch-py/
+ https://github.com/opensearch-project/opensearch-py
+"
+SRC_URI="
+ https://github.com/opensearch-project/opensearch-py/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Uses 156 GB of RAM for the test suite, needs more work.
+RESTRICT="test"
+
+RDEPEND="
+ <dev-python/urllib3-2[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ )
+"
diff --git a/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild b/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild
new file mode 100644
index 000000000000..07abb4d2627b
--- /dev/null
+++ b/dev-python/opensearch-py/opensearch-py-2.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for OpenSearch"
+HOMEPAGE="
+ https://pypi.org/project/opensearch-py/
+ https://github.com/opensearch-project/opensearch-py
+"
+SRC_URI="
+ https://github.com/opensearch-project/opensearch-py/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+# Uses 156 GB of RAM for the test suite, needs more work.
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/urllib3-1.21.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.0[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/certifi[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/botocore[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"