summaryrefslogtreecommitdiff
path: root/dev-python/openpyxl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-01 00:07:06 +0100
commit1551fe56fd6ba43a94509cffc61b6bf854b7ac9f (patch)
treebe99b6ceb874878a108d68c641b476a2df076517 /dev-python/openpyxl
parent0e2a727aba684f1a44cc0402a3f77d242140681b (diff)
gentoo auto-resync : 01:06:2024 - 00:07:06
Diffstat (limited to 'dev-python/openpyxl')
-rw-r--r--dev-python/openpyxl/Manifest2
-rw-r--r--dev-python/openpyxl/openpyxl-3.1.3.ebuild52
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/openpyxl/Manifest b/dev-python/openpyxl/Manifest
index 30a6e67d4807..8a88efb14eb8 100644
--- a/dev-python/openpyxl/Manifest
+++ b/dev-python/openpyxl/Manifest
@@ -1,4 +1,6 @@
AUX openpyxl-3.1.2-pytest-8.patch 3319 BLAKE2B dba24fc7ef1164141ac34fb4000936cb8355ff69238a91cada39df2d5018888ff8d1a78f22babd72dbba7162e38d2bdb3e30b36064abb1bd3666b7fbef905ecd SHA512 bb9ca4910743eb66870f4e9d8ff1ee18e54d042a4a638b2d49dd2677b256caa19f454c66b2dfe3601adff132159ae4e998363814117dba2b0cf8e0b33a966a44
DIST openpyxl-3.1.2.tar.bz2 2733302 BLAKE2B 7030c698c2dfa3c3f27f23485e33cc9f4ffc0c473e590785ebfa03a958f7c1deab98503890b7350f32cbb4607b3fbf543b35299c0f8abfbfcc779e96ddda9ee1 SHA512 307d82dcf839c60be606c01f862701f69017573894c7fd26e35ec3edead2ea2a126aecca61b0c7f6727ff834dd6bed844095b9a56f2b510689ab071926a7a742
+DIST openpyxl-3.1.3.tar.bz2 2739587 BLAKE2B 64161f8ea0629f4bd2ef65187c2d1c0cfa23e155df7b5a4a81c386c48d339956e3d854da040157170852df19ab53d65fd0be9a4f1d4f5b5f6eed20e0fe1e89f9 SHA512 dee9dac201319ed6b3c14cb0cd396148a7caedebb2a95534a1b9fcb75afc445bfd73e67fdbd750334872e4bd3bf1a71d20c48930ff6b195f4f1c6312a5e762f8
EBUILD openpyxl-3.1.2.ebuild 1702 BLAKE2B eaad07d111bcf7b16604d2b5fe7cfff9fb410c5adcf8879c95db33842e4ae32d25f55b3fa308a88d3047d0047e4ae4c303ad5b84538c7ab7579295f27c4d3e9c SHA512 a032a1ac383d01c3acd246267348c3b0d6784f66a5b127f271459e71702a065f459e6d35a9e7383af15c1741357e0a027d771e4952690747e5582ad6b8f89c31
+EBUILD openpyxl-3.1.3.ebuild 1225 BLAKE2B 6f1cc837fe66cbef22802eeaaff776eedb2460d31f4f42681d8e1c535a3f94dede4a004e5c6e6288933d945d2256330f5b8a7aa63edbd7ddd6c53e4ce54f57e9 SHA512 09c5e01c7db34f6835e492cdffdeedc2d19d33f3aa41d9d3f4cf9335eddc70111b9e240436b56b05e7ed941c224ce039b624a8406928250974dc753bdc4eafce
MISC metadata.xml 595 BLAKE2B c843c395f1b6a40fea607fa7f851af887fce236ad6fc5b6b77eea0b208954a3340f49ab66a5503f6951346718ecfaf5d43f1a0bbee9b86f4b11c29b1e4cb6394 SHA512 a0cc42713e9c67438050b44c810f17ab4946f8a1eece0159e71d4abe749047dd44ff430605bf5c34af12de2abe4937955c7aade0c5af708ed7f6b816684c8763
diff --git a/dev-python/openpyxl/openpyxl-3.1.3.ebuild b/dev-python/openpyxl/openpyxl-3.1.3.ebuild
new file mode 100644
index 000000000000..e1d43c5174d6
--- /dev/null
+++ b/dev-python/openpyxl/openpyxl-3.1.3.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure python reader and writer of Excel OpenXML files"
+HOMEPAGE="
+ https://openpyxl.readthedocs.io/en/stable/
+ https://foss.heptapod.net/openpyxl/openpyxl/
+"
+SRC_URI="
+ https://foss.heptapod.net/openpyxl/openpyxl/-/archive/${PV}/${P}.tar.bz2
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ dev-python/et-xmlfile[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/lxml-5.0.3[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff,jpeg]
+ )
+"
+
+distutils_enable_sphinx doc \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # GC assumptions (pypy)
+ openpyxl/tests/test_iter.py::test_file_descriptor_leak
+ )
+
+ if has_version ">=dev-python/numpy-2[${PYTHON_USEDEP}]"; then
+ EPYTEST_DESELECT+=(
+ # https://foss.heptapod.net/openpyxl/openpyxl/-/issues/2187
+ openpyxl/compat/tests/test_compat.py::test_numpy_tostring
+ )
+ fi
+
+ epytest
+}