summaryrefslogtreecommitdiff
path: root/dev-python/openapi-spec-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 22:29:52 +0000
commit4dc9bfa1f12673bbf1343e64af7e0cd715534a9f (patch)
treeb6bfc88046aa092bbc03342aef7eccf310d43692 /dev-python/openapi-spec-validator
parent8cd3c41aa0ccead302235680b9e2fa9903d7548e (diff)
gentoo auto-resync : 25:11:2023 - 22:29:52
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest2
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild50
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
index 5efcb982b502..2dfeeb12cf52 100644
--- a/dev-python/openapi-spec-validator/Manifest
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -1,5 +1,3 @@
-DIST openapi_spec_validator-0.6.0.tar.gz 33646 BLAKE2B cf8d397602b147872e86c0f236731ec477e20775aa63a61162e66deb7d4b81ef91bd86b67d2dfddf5d6b160c37b7eab4ddb1d10975ada8dc13aebdc088e4483a SHA512 71434f131f34902210237940d75f07f250b296c3e1814e03f0eaae436321ca11ac63d0014c85ad571852e66b2e11545c9d0cf21d771c0c67210a60c1f9094cc2
DIST openapi_spec_validator-0.7.1.tar.gz 37985 BLAKE2B e4e6995bba18ea9fb65be28b2156c73afd3c5074a3fbd5b83e03534a1bb5fdde2e5a586aa161e0f9fc64985d83ae995f46ff2704a4010a708f9e0cf18f97a8a8 SHA512 c2a4be4a945058a4e77857bf0d6dabf2bef27c25fbe72947db3ac011c5a60d2d0159ef0d1d44571152c5ffdc650f7d3d6c54f82834e499e9506fb474b7c9b270
-EBUILD openapi-spec-validator-0.6.0.ebuild 1638 BLAKE2B d1df9e4134eeec0e60aa472ffc39863b1517859036c93acdb3c1326c2d79c1e032b660a57d30b67d3e36ed423cadb85d587278d927b7b1ec2ceb6448b4c30934 SHA512 ba9115acb4927a8a024b4dfcc20f2c506547368d5a172560e96d2763975acfc9425ab497c3551f55ec40df0652dd41e923003a35f6afe21fbc880e1fc76d57a9
EBUILD openapi-spec-validator-0.7.1.ebuild 1638 BLAKE2B 96a5b6bd23cf4f2ec1df249582cd1bf61c2be4ddccdf2bf45b09f4a15567ff5231084c668f53e942be49b3023de5f8d47d501079167c7775d254c42bf61e84a6 SHA512 cfb5358e81a90e1aeba86b74af00eb1bc2db2dc3cbc4f4bb5a2e876fdf58190ee594f939736aef6201bfd3451bba977f875815ed145584c7c2208dc9b4ca631a
MISC metadata.xml 405 BLAKE2B 82dfdb0a9a068a90ad245a33da95883f863571b12e3d354cee5b7e10b9c098f3635b25fc1871db3b384c5218c2305c90e9f185c97619ba142735b03de90bde01 SHA512 a3f926750e11ce7b8960fa7adef139a329b7dac777c78acfc2cf24225862d8f04a2bb8edba36f99aabd1ea44f93220afefafe060dce6418fa03f360c129a344c
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
deleted file mode 100644
index bb2e7745920b..000000000000
--- a/dev-python/openapi-spec-validator/openapi-spec-validator-0.6.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( pypy3 python3_{10..12} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
-HOMEPAGE="
- https://github.com/python-openapi/openapi-spec-validator/
- https://pypi.org/project/openapi-spec-validator/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~loong ppc64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/jsonschema-4.18.0[${PYTHON_USEDEP}]
- >=dev-python/jsonschema-spec-0.2.3[${PYTHON_USEDEP}]
- >=dev-python/lazy-object-proxy-1.7.1[${PYTHON_USEDEP}]
- >=dev-python/openapi-schema-validator-0.6.0[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # Internet
- tests/integration/test_shortcuts.py::TestPetstoreV2Example
- tests/integration/test_shortcuts.py::TestApiV2WithExampe
- tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
- tests/integration/test_shortcuts.py::TestPetstoreExample
- tests/integration/test_shortcuts.py::TestRemoteValidatev2SpecUrl
- tests/integration/test_shortcuts.py::TestRemoteValidatev30SpecUrl
- tests/integration/test_shortcuts.py::TestApiWithExample
- tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
- tests/integration/test_validate.py::TestPetstoreExample
- tests/integration/test_validate.py::TestApiWithExample
- tests/integration/test_validate.py::TestPetstoreExpandedExample
- tests/integration/validation/test_validators.py
-)
-
-src_prepare() {
- sed -i -e '/--cov/d' pyproject.toml || die
- distutils-r1_src_prepare
-}