summaryrefslogtreecommitdiff
path: root/dev-python/openapi-spec-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/openapi-spec-validator
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/openapi-spec-validator')
-rw-r--r--dev-python/openapi-spec-validator/Manifest3
-rw-r--r--dev-python/openapi-spec-validator/metadata.xml11
-rw-r--r--dev-python/openapi-spec-validator/openapi-spec-validator-0.4.0.ebuild51
3 files changed, 65 insertions, 0 deletions
diff --git a/dev-python/openapi-spec-validator/Manifest b/dev-python/openapi-spec-validator/Manifest
new file mode 100644
index 000000000000..000f3647e540
--- /dev/null
+++ b/dev-python/openapi-spec-validator/Manifest
@@ -0,0 +1,3 @@
+DIST openapi-spec-validator-0.4.0.gh.tar.gz 46051 BLAKE2B 43a1458ab1801700261f750e49d45b0cb4d02f1c17a16943b5232836061e0e1466fc973343bbd4bf7a8669b682bd6761cb905fdfb3b80c0b9720253cc2d5a926 SHA512 d2eaf22c75e72eb5061a916eb37b13179a5ba65eb8a00ec42e81c6b4168239bc8613388f2d77ce35113d260385b175280d8863a3deedf18ea5aa93a79f058419
+EBUILD openapi-spec-validator-0.4.0.ebuild 1503 BLAKE2B 9630f20e77d363c1dbc99ab2a3cc6a5732fb1a9931fb39a7070e8822b24f4d45310b53287ca0c6fe3c09bd6f4a0f7acf01233b60b79c040954fd42fa36efddf2 SHA512 0c8f2cfbc74d2235fc83f579a33f781972b6756a632074ccea4a41f87014286b9edefb23d14fa3e311b81350372387ddd463a758d3f69c5c705ddb8a64db25af
+MISC metadata.xml 372 BLAKE2B 6b08d5f1a63e2ddf4c0f1ab8479a18109231211c82a2a1178a9e1d0775ad0fd5811580c3b2175137ec135b6c8d8ad0e0d728d79da98c092fd87fc604c7cc8a4f SHA512 4fe628abc1481b9dd5874dd5efaaefa5f1adf24e2e58183d2ca75677680077a443702887bb21c67049df998052dc6afae590ac9197b6edb87cc10c126ae22345
diff --git a/dev-python/openapi-spec-validator/metadata.xml b/dev-python/openapi-spec-validator/metadata.xml
new file mode 100644
index 000000000000..f1585fdeea72
--- /dev/null
+++ b/dev-python/openapi-spec-validator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">p1c2u/openapi-spec-validator</remote-id>
+ <remote-id type="pypi">openapi-spec-validator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/openapi-spec-validator/openapi-spec-validator-0.4.0.ebuild b/dev-python/openapi-spec-validator/openapi-spec-validator-0.4.0.ebuild
new file mode 100644
index 000000000000..c86f945de79b
--- /dev/null
+++ b/dev-python/openapi-spec-validator/openapi-spec-validator-0.4.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI 2.0 (aka Swagger) and OpenAPI 3.0 spec validator"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-spec-validator/
+ https://pypi.org/project/openapi-spec-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-spec-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/jsonschema-3.2.0[${PYTHON_USEDEP}]
+ >=dev-python/openapi-schema-validator-0.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # Internet
+ tests/integration/test_shortcuts.py::TestPetstoreV2Example
+ tests/integration/test_shortcuts.py::TestApiV2WithExampe
+ tests/integration/test_shortcuts.py::TestPetstoreV2ExpandedExample
+ tests/integration/test_shortcuts.py::TestPetstoreExample
+ tests/integration/test_shortcuts.py::TestApiWithExample
+ tests/integration/test_shortcuts.py::TestPetstoreExpandedExample
+ tests/integration/test_validate.py::TestPetstoreExample
+ tests/integration/test_validate.py::TestApiWithExample
+ tests/integration/test_validate.py::TestPetstoreExpandedExample
+)
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}