summaryrefslogtreecommitdiff
path: root/dev-python/openapi-schema-validator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/openapi-schema-validator
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/openapi-schema-validator')
-rw-r--r--dev-python/openapi-schema-validator/Manifest5
-rw-r--r--dev-python/openapi-schema-validator/metadata.xml11
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild37
-rw-r--r--dev-python/openapi-schema-validator/openapi-schema-validator-0.3.0.ebuild38
4 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/openapi-schema-validator/Manifest b/dev-python/openapi-schema-validator/Manifest
new file mode 100644
index 000000000000..1a85d8aa4ae5
--- /dev/null
+++ b/dev-python/openapi-schema-validator/Manifest
@@ -0,0 +1,5 @@
+DIST openapi-schema-validator-0.2.3.gh.tar.gz 25501 BLAKE2B d961cabca647f59d4d4188f1941ce5b2475e02520bcc10e7cd29817c8ea8ebaaac5af1ffb0e3d5079ed2d1493414cdaf55336744b142385754585e748af8ac98 SHA512 e6dfe3d6cc99fa9723102ced42040203157639be68b0438d7bfae4499e51cdb6257a36dca10425a5d5e692cebb958468ebeee722116b99d800a6fcf972400c66
+DIST openapi-schema-validator-0.3.0.gh.tar.gz 27083 BLAKE2B 288f5d18874625c69eccf9be6442258ff8af735795eac0ee0449e5976584b1af22c1ea771bb79b4fa68623e60d417b140737e0d1ee85791027393650f0c1f747 SHA512 003ea97a1cac598eb3728d96291d8be56c6ba9e2d3cd4f77c1258962f67b460a887f4473fed39587870583e13a83403623c3b2f96fa8d02345583cd3bdaf008b
+EBUILD openapi-schema-validator-0.2.3.ebuild 857 BLAKE2B eb473e375f925dc889aafd6ffbae05880a663acb1b4a929795f9ef555e6dd92591aedc9f092e593fd3b8f8500b62f36d3e7101a791baf24296639fab7c39dfb3 SHA512 98c81c69daffc9d3f19a686e9b343ac0fd5bd74a966a129259d953895066c5216c6d6398372fe053c08b92b3da2915b204b3a5df5f183d51a5c91fc3b5b6f8ed
+EBUILD openapi-schema-validator-0.3.0.ebuild 900 BLAKE2B 12a9c332ed2c45205ce5bd62b138fcaea9cbcf2a032593123ecd0d86f026316f3c4a404480fa74c10b8e5a160622e8ff47309ed17490fe1437b260a7bbaaa26b SHA512 2e0722818e1a038e3a399a1936b358f1f71245eeb773e5bd696245727b35996f6136bcc661907786e0a841ddb3e3e19e87b4ad4d0ffa479ef7ce64db7a63bdb8
+MISC metadata.xml 376 BLAKE2B 6812229fbb8f1d8d5b21b7717bc6494f9c07cacfbb0b7b5510206557d295d91fbe942f5c2a24c8841447f2e6e0077f949d81720061b6f8cbe56f4772d9dcb6bb SHA512 8fa107a7a073629d9115e7d42aa532f5b4f1d955a522076ff8c515e98fe69192474e40eec08952d4287d8299afe36ea811c709e1b502c0489cb3511ebf748c53
diff --git a/dev-python/openapi-schema-validator/metadata.xml b/dev-python/openapi-schema-validator/metadata.xml
new file mode 100644
index 000000000000..b4e6776314fc
--- /dev/null
+++ b/dev-python/openapi-schema-validator/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">p1c2u/openapi-schema-validator</remote-id>
+ <remote-id type="pypi">openapi-schema-validator</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild
new file mode 100644
index 000000000000..62d30a279c6b
--- /dev/null
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI schema validation for Python"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-schema-validator/
+ https://pypi.org/project/openapi-schema-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-schema-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}
diff --git a/dev-python/openapi-schema-validator/openapi-schema-validator-0.3.0.ebuild b/dev-python/openapi-schema-validator/openapi-schema-validator-0.3.0.ebuild
new file mode 100644
index 000000000000..b25ebd5a26c8
--- /dev/null
+++ b/dev-python/openapi-schema-validator/openapi-schema-validator-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="OpenAPI schema validation for Python"
+HOMEPAGE="
+ https://github.com/p1c2u/openapi-schema-validator/
+ https://pypi.org/project/openapi-schema-validator/
+"
+SRC_URI="
+ https://github.com/p1c2u/openapi-schema-validator/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
+ dev-python/isodate[${PYTHON_USEDEP}]
+ >=dev-python/jsonschema-4.0.0[${PYTHON_USEDEP}]
+ dev-python/rfc3339-validator[${PYTHON_USEDEP}]
+ dev-python/strict-rfc3339[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/--cov/d' pyproject.toml || die
+ distutils-r1_src_prepare
+}