summaryrefslogtreecommitdiff
path: root/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild')
-rw-r--r--dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild b/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild
new file mode 100644
index 000000000000..c7fabb9fae34
--- /dev/null
+++ b/dev-python/onkyo-eiscp/onkyo-eiscp-1.2.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Control Onkyo A/V receivers over the network"
+HOMEPAGE="https://github.com/miracle2k/onkyo-eiscp https://pypi.org/project/onkyo-eiscp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/docopt-0.4.1[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-exclude-tests.patch )