summaryrefslogtreecommitdiff
path: root/dev-python/odfpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-08 20:11:47 +0100
commitf625b9919a60a30f1bd860f7d1b2eac183ced593 (patch)
tree7543f00925ff7277e31881de0a87801681f6f92f /dev-python/odfpy
parente3872864be25f7421015bef2732fa57c0c9fb726 (diff)
gentoo resync : 08.08.2018
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/Manifest2
-rw-r--r--dev-python/odfpy/odfpy-1.3.6.ebuild33
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/odfpy/Manifest b/dev-python/odfpy/Manifest
index 1bb4599d4a73..66b67bb9e154 100644
--- a/dev-python/odfpy/Manifest
+++ b/dev-python/odfpy/Manifest
@@ -1,3 +1,5 @@
DIST odfpy-1.3.2.tar.gz 479554 BLAKE2B 3b9d2d144f11727471002dd1dfb9289028423d05d65fea040041dbd43a674ddf6c893fa8895a2e198e6a82e79aa2af92f21a6381cfd67233b4fe57401370121f SHA512 c5be79c4077f40a56821790d4b6062e3715f8b616b1e9ead79977ad00ecf3f506ebbe73790f215bb835a233833fa471af7f619cfcd88320cf8238e4c9502e248
+DIST odfpy-1.3.6.tar.gz 691122 BLAKE2B aaaf2c1613beb6775d22e4d1739b7c144d8046e687f0dc8f7b7b1ea7400cc32dd572ed5a1cd12cb01c5fec27b5c37950b710b279a46d60da8735154d2b2d7030 SHA512 09f3fbce633949035842cff16d2e016271b7f6abf04d74fcaa712c9b3afa18943dd566a2d88a7256a0a52d88ea689d6ef8262f6d8d67d6ea1025aa56e10300f8
EBUILD odfpy-1.3.2.ebuild 1087 BLAKE2B bc285573ca2b541623371ff7f7de62e7c5444a777f7fdb69008a59ac848a8889dd339657e17345d2f6eeccb81791dac22510512d9eacbe400cb303ac03acb9e8 SHA512 82b609783b919de843845c2c358c1fbe5e23701ee960fa0e7445f5d98deec87a3cdbb774fb90241460624719efc0e3ca3539e50073266a62e9a04c7af5029ab6
+EBUILD odfpy-1.3.6.ebuild 892 BLAKE2B fffa9347f451e7b899e797b6767dc18919c59791c2a5aa44407543003d2bfcf8c10a8ff5ce582e5ec186cb43c755a39498e86786510a9c3ce5994af9125b574f SHA512 a42fade914429e04f2d688f047d1e6e1577cdc1c426548016ddd8302da2f0169bf90b48eae58e47ecb93d0f78867817412595b7346a0bacb2c3f7266a3254865
MISC metadata.xml 308 BLAKE2B 4d370440c480d97acc4b9b2e51aeb78f27227e8dd2c5acfdb99747b6b2eabdd624f8a8f90af28287849216d874bbcc81bb9ca8cbf78c1221e947fd479476b1db SHA512 919a3c6c182828bf99396da71e83f0b982aadcdf0e0c5e6e7f29e15cab19e2d3c6d5afc26864a324055e97be9563cc30ef10b701716678c7cd44e8403adaccde
diff --git a/dev-python/odfpy/odfpy-1.3.6.ebuild b/dev-python/odfpy/odfpy-1.3.6.ebuild
new file mode 100644
index 000000000000..35d1e10f5509
--- /dev/null
+++ b/dev-python/odfpy/odfpy-1.3.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# Classifier: Programming Language :: Python :: 2 :: Only
+# py3 fails one test, pypy anpother.
+# Notes on page of home repo reports support of python3.
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://github.com/eea/odfpy https://pypi.org/project/odfpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ pytest -v || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}