summaryrefslogtreecommitdiff
path: root/dev-python/odfpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/odfpy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/Manifest3
-rw-r--r--dev-python/odfpy/metadata.xml11
-rw-r--r--dev-python/odfpy/odfpy-1.3.2.ebuild40
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/odfpy/Manifest b/dev-python/odfpy/Manifest
new file mode 100644
index 000000000000..1bb4599d4a73
--- /dev/null
+++ b/dev-python/odfpy/Manifest
@@ -0,0 +1,3 @@
+DIST odfpy-1.3.2.tar.gz 479554 BLAKE2B 3b9d2d144f11727471002dd1dfb9289028423d05d65fea040041dbd43a674ddf6c893fa8895a2e198e6a82e79aa2af92f21a6381cfd67233b4fe57401370121f SHA512 c5be79c4077f40a56821790d4b6062e3715f8b616b1e9ead79977ad00ecf3f506ebbe73790f215bb835a233833fa471af7f619cfcd88320cf8238e4c9502e248
+EBUILD odfpy-1.3.2.ebuild 1087 BLAKE2B bc285573ca2b541623371ff7f7de62e7c5444a777f7fdb69008a59ac848a8889dd339657e17345d2f6eeccb81791dac22510512d9eacbe400cb303ac03acb9e8 SHA512 82b609783b919de843845c2c358c1fbe5e23701ee960fa0e7445f5d98deec87a3cdbb774fb90241460624719efc0e3ca3539e50073266a62e9a04c7af5029ab6
+MISC metadata.xml 308 BLAKE2B 4d370440c480d97acc4b9b2e51aeb78f27227e8dd2c5acfdb99747b6b2eabdd624f8a8f90af28287849216d874bbcc81bb9ca8cbf78c1221e947fd479476b1db SHA512 919a3c6c182828bf99396da71e83f0b982aadcdf0e0c5e6e7f29e15cab19e2d3c6d5afc26864a324055e97be9563cc30ef10b701716678c7cd44e8403adaccde
diff --git a/dev-python/odfpy/metadata.xml b/dev-python/odfpy/metadata.xml
new file mode 100644
index 000000000000..eb4477be8452
--- /dev/null
+++ b/dev-python/odfpy/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">odfpy</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/odfpy/odfpy-1.3.2.ebuild b/dev-python/odfpy/odfpy-1.3.2.ebuild
new file mode 100644
index 000000000000..90ff23ae2b34
--- /dev/null
+++ b/dev-python/odfpy/odfpy-1.3.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+# Classifier: Programming Language :: Python :: 2 :: Only
+# py3 fails one test, pypy anpother.
+# Notes on page of home repo reports support of python3.
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="https://github.com/eea/odfpy https://pypi.org/project/odfpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+# Tarball missing required folder to build docs in html.
+
+python_test() {
+ # Known single fail under python3 suspected to be caused in python3 itself
+ # https://github.com/eea/odfpy/issues/21
+
+ local exit_status=0 test
+ for test in tests/test*.py; do
+ einfo "Running ${test} ..."
+ "${PYTHON}" ${test}
+ [[ $? -ne 0 ]] && exit_status=1
+ done
+ return ${exit_status}
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}