summaryrefslogtreecommitdiff
path: root/dev-python/objgraph/objgraph-3.4.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /dev-python/objgraph/objgraph-3.4.0.ebuild
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'dev-python/objgraph/objgraph-3.4.0.ebuild')
-rw-r--r--dev-python/objgraph/objgraph-3.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/objgraph/objgraph-3.4.0.ebuild b/dev-python/objgraph/objgraph-3.4.0.ebuild
new file mode 100644
index 000000000000..9a701f9fbbdf
--- /dev/null
+++ b/dev-python/objgraph/objgraph-3.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Draws Python object reference graphs with graphviz"
+HOMEPAGE="https://mg.pov.lt/objgraph/"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="media-gfx/graphviz"
+DEPEND="dev-python/setuptools
+ test? ( media-gfx/xdot )"
+
+python_test() {
+ esetup.py test || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/* )
+ distutils-r1_python_install_all
+}