summaryrefslogtreecommitdiff
path: root/dev-python/oauthlib
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-11 00:08:05 +0100
commit65ff3cc3bd9c3f8e718a67dfecf1f8215bf5d1d4 (patch)
tree541cbae0eb51d2fdb39d64b3d135d1a6f7994dc8 /dev-python/oauthlib
parent0aad4cd3e3fe3db90904ffc51b35e4ff160b53c5 (diff)
gentoo auto-resync : 11:06:2024 - 00:08:04
Diffstat (limited to 'dev-python/oauthlib')
-rw-r--r--dev-python/oauthlib/Manifest3
-rw-r--r--dev-python/oauthlib/files/oauthlib-3.2.2-py313.patch37
-rw-r--r--dev-python/oauthlib/oauthlib-3.2.2.ebuild9
3 files changed, 46 insertions, 3 deletions
diff --git a/dev-python/oauthlib/Manifest b/dev-python/oauthlib/Manifest
index 1528db607f3d..94319cfe6491 100644
--- a/dev-python/oauthlib/Manifest
+++ b/dev-python/oauthlib/Manifest
@@ -1,3 +1,4 @@
+AUX oauthlib-3.2.2-py313.patch 1737 BLAKE2B 7786d91f0493d68c17f28cccd0e86e0aba03ca776902ee00f53a4a1313e24419c36f34040795c358dc672710957f9faae1301ae1757ef3ce69e62a904b7096ea SHA512 8f72fed92e520e96c66c45d954c5e33f6c1ab2eef601232eb2010568446e6aa49895dee4f3aea0faa035562d06e34231585b52b842a77ada92db28eb67188e8e
DIST oauthlib-3.2.2.tar.gz 177352 BLAKE2B 98c128eb0ec2a24f45fd63826eb2253e2e90afb37c1954a9d21f0046168bfff8d52a24b230b60f4d756e4730c0cc05b3484d2cb6ac3eb2d710ee113dea6598c9 SHA512 c147b96e0ab0d1a8845f525e80831cfd04495134dd1f17fd95eac62f3a95c91e6dca9d38e34206537d77f3c12dd5b553252239318ba39546979c350e96536b8b
-EBUILD oauthlib-3.2.2.ebuild 678 BLAKE2B d78e78b0b7cb86d1d034350b6f6e861c07fa24a0371458dd39e60f1ade5ca6994102c0fe55a070aafb43875aa604db00b0b50ebd7624d0a938976a6932d1043f SHA512 4bfd012a57f544c002beb50a8851f9a2f6304a696577983b028cd450de0c5418764bef3cc56a56450cd2161a895184b8a2c65b36b057b9fc66a19c703c414988
+EBUILD oauthlib-3.2.2.ebuild 811 BLAKE2B cb67b238fa87e29ed55d3a10523e2eade6a66a8ed49f8698bf5288b974073cfab117887b49fc3cbfc47211d44390ab206ad3ed64a842f20d66dd0904e969eb3b SHA512 0f2cb4819fe96de6ab68f338d11b033c8dc4ef07a73b01c9b0fd4993bc3c82913d9689e3c21e97390d62ea5ad0a1f1f7777135d8150fc422e377744e7b30780e
MISC metadata.xml 462 BLAKE2B f55c4f728fa3876547335d39e23c0ad548729501da250e30455077ce7e6816135c58125f579fa306a11ce527f6d7dd8f48ac2f8eb52ea7ad8d6d41bcc5cd142a SHA512 43a7a62ae73e1733e27cdc10150bfde2007a0b05f0ac1c2146329e5ca0e38e4a69cac1f61350279e74980e75c371b7c12dacc0d6c73806cc34a2c1b49ced9f43
diff --git a/dev-python/oauthlib/files/oauthlib-3.2.2-py313.patch b/dev-python/oauthlib/files/oauthlib-3.2.2-py313.patch
new file mode 100644
index 000000000000..2d000e5e1b1b
--- /dev/null
+++ b/dev-python/oauthlib/files/oauthlib-3.2.2-py313.patch
@@ -0,0 +1,37 @@
+From fe020db74199d5284c00d7735aa7d4ddc90f5d61 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Miro=20Hron=C4=8Dok?= <miro@hroncok.cz>
+Date: Tue, 24 Oct 2023 15:08:10 +0200
+Subject: [PATCH] Make UtilsTests.test_filter_params Python 3.13+ compatible
+
+Since Python 3.13.0a1, docstrings are automatically dedented.
+See https://github.com/python/cpython/issues/81283
+and https://docs.python.org/3.13/whatsnew/3.13.html#other-language-changes
+
+As a result, using a docstring with leading space as a test case
+breaks the test assumption.
+
+The initial commit which introduced this test a decade ago
+(6c0c7914f3a57823834b1be492b307992f943629)
+does not specify why testing the spaces is important.
+---
+ tests/oauth1/rfc5849/test_utils.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tests/oauth1/rfc5849/test_utils.py b/tests/oauth1/rfc5849/test_utils.py
+index 013c71a9..22128908 100644
+--- a/tests/oauth1/rfc5849/test_utils.py
++++ b/tests/oauth1/rfc5849/test_utils.py
+@@ -53,11 +53,11 @@ def test_filter_params(self):
+ # The following is an isolated test function used to test the filter_params decorator.
+ @filter_params
+ def special_test_function(params, realm=None):
+- """ I am a special test function """
++ """I am a special test function"""
+ return 'OAuth ' + ','.join(['='.join([k, v]) for k, v in params])
+
+ # check that the docstring got through
+- self.assertEqual(special_test_function.__doc__, " I am a special test function ")
++ self.assertEqual(special_test_function.__doc__, "I am a special test function")
+
+ # Check that the decorator filtering works as per design.
+ # Any param that does not start with 'oauth'
diff --git a/dev-python/oauthlib/oauthlib-3.2.2.ebuild b/dev-python/oauthlib/oauthlib-3.2.2.ebuild
index 74d6c2f9c0ab..51553f97b2fb 100644
--- a/dev-python/oauthlib/oauthlib-3.2.2.ebuild
+++ b/dev-python/oauthlib/oauthlib-3.2.2.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 pypi
@@ -26,3 +26,8 @@ RDEPEND="
"
distutils_enable_tests unittest
+
+PATCHES=(
+ # https://github.com/oauthlib/oauthlib/commit/fe020db74199d5284c00d7735aa7d4ddc90f5d61
+ "${FILESDIR}/${P}-py313.patch"
+)