summaryrefslogtreecommitdiff
path: root/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild')
-rw-r--r--dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
deleted file mode 100644
index dcf5e4e10dd9..000000000000
--- a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-MY_P="${P/_p/.post}"
-
-DESCRIPTION="Library for OAuth version 1.0"
-HOMEPAGE="https://pypi.org/project/oauth2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-
-RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
-DEPEND="
- test? ( ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- )"
-
-# https://github.com/joestump/python-oauth2/pull/212
-PATCHES=(
- "${FILESDIR}/${PV}-exclude-tests.patch"
-)
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # These tests require network access
- tests/test_oauth.py::TestClient::test_access_token_get
- tests/test_oauth.py::TestClient::test_access_token_post
- tests/test_oauth.py::TestClient::test_two_legged_get
- tests/test_oauth.py::TestClient::test_two_legged_post
-)