summaryrefslogtreecommitdiff
path: root/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild')
-rw-r--r--dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild b/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
deleted file mode 100644
index 9587054d0e20..000000000000
--- a/dev-python/oauth2/oauth2-1.9.0_p1-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
-
-inherit distutils-r1
-
-MY_P="${P/_p/.post}"
-
-DESCRIPTION="Library for OAuth version 1.0"
-HOMEPAGE="https://pypi.org/project/oauth2/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="test"
-
-RDEPEND="dev-python/httplib2[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- )"
-
-# https://github.com/joestump/python-oauth2/pull/212
-PATCHES=( "${FILESDIR}/${PV}-exclude-tests.patch" )
-S="${WORKDIR}/${MY_P}"
-
-python_test() {
- # Skip tests which require network access
- py.test -k "not (test_access_token_post or test_access_token_get \
- or test_two_legged_post or test_two_legged_get)" || die \
- "tests failed with ${EPYTHON}"
-}