summaryrefslogtreecommitdiff
path: root/dev-python/numpydoc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /dev-python/numpydoc
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'dev-python/numpydoc')
-rw-r--r--dev-python/numpydoc/Manifest2
-rw-r--r--dev-python/numpydoc/numpydoc-1.2.1.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/numpydoc/Manifest b/dev-python/numpydoc/Manifest
index 798e1921b7fc..b4efb4fe8bc1 100644
--- a/dev-python/numpydoc/Manifest
+++ b/dev-python/numpydoc/Manifest
@@ -1,3 +1,5 @@
+DIST numpydoc-1.2.1.tar.gz 70350 BLAKE2B f693436efa8e95527e4d7d20676b1f3e563369190a71cc4e2cc8ec38b65ad500f3e0e8a4e89ce48ebd3bf1190c8fff1ead05cc22dbbf80fdf147b9996b2b5add SHA512 439ff422d46ea8eaa26bd14ac41f8d64638d8df081a3b889eaadceafbde64f2a091f6363d0565759618d60c4fe869d8f62ec0878d45674022056058621048d0e
DIST numpydoc-1.2.tar.gz 69659 BLAKE2B e5483ad3d6d82e9ff51d2d7cdc36c75407361059a696047f1d0fb7d3307c36ee056e8c0b9eb45fc11e4d341350c1b1dd021d60252055154c6907942e549b9555 SHA512 b8ea82a947c7fca9d02c2083f6040f2a1a115400e43257fd6ce7ac9b1b174d22ed7723053b87893d6bff8f47a625932297c884e853be4e00d3ae2262ad0161cf
+EBUILD numpydoc-1.2.1.ebuild 1016 BLAKE2B da616537e26fa7dbdb561c8b36fc1837fc3df7c11902560f5af120bd87fd82e1c56c0283a733644d26923d0a2e18555ba18fdc51b6f7fba5d18da490f4cbb6d7 SHA512 c32991d468abe435fdbd5a68e6b505f5228319543d7d0d014b724328017119fd6cb570438fd3e6abb042fe89bff3a55e3bff2cf5704e1c5370558a822f85e0bf
EBUILD numpydoc-1.2.ebuild 1008 BLAKE2B af23e49a4e3599f7ae80c717095cb3f8c758e8e6f8265901db7c315718517ca6ebfaafd39bb4c7b665631e0a416d717743c95ede1fc0892344e847f77fb118da SHA512 97aab5ab6d369fe625b2108d6913df429e5af8f09fa3f9872f768fab1d797714c5bb9ad4bd3a94890a3d9f7b8583ea2678ea2f1b5a19d6084a301cef78554240
MISC metadata.xml 403 BLAKE2B 437fdd3881a5ec60a83b3cb018e57c714a91030be9ab0032b8662e30b7bcd120ee3dd2015be561dd8a65a39833ef777e22f040a6e466c1b56a602a4ac33d4917 SHA512 833d00712cf7dfdc1080181301c03388a3c966436d2d9c9badb609cff66fa49035a6d001d60f205e1c2c49808eda7fad65abda8802f42f7ba36939b3691a8390
diff --git a/dev-python/numpydoc/numpydoc-1.2.1.ebuild b/dev-python/numpydoc/numpydoc-1.2.1.ebuild
new file mode 100644
index 000000000000..f59030e0df57
--- /dev/null
+++ b/dev-python/numpydoc/numpydoc-1.2.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Sphinx extension to support docstrings in Numpy format"
+HOMEPAGE="https://pypi.org/project/numpydoc/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/jinja-2.10[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/matplotlib-3.2.1[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e 's:--cov-report= --cov=numpydoc::' setup.cfg || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # these require Internet (intersphinx)
+ numpydoc/tests/test_full.py::test_MyClass
+ numpydoc/tests/test_full.py::test_my_function
+ )
+ epytest --pyargs numpydoc
+}