summaryrefslogtreecommitdiff
path: root/dev-python/numexpr/numexpr-2.7.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/numexpr/numexpr-2.7.3.ebuild
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/numexpr/numexpr-2.7.3.ebuild')
-rw-r--r--dev-python/numexpr/numexpr-2.7.3.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/numexpr/numexpr-2.7.3.ebuild b/dev-python/numexpr/numexpr-2.7.3.ebuild
new file mode 100644
index 000000000000..78f0a10f5478
--- /dev/null
+++ b/dev-python/numexpr/numexpr-2.7.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
+HOMEPAGE="https://github.com/pydata/numexpr"
+SRC_URI="https://github.com/pydata/numexpr/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="mkl"
+
+RDEPEND="
+ >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
+ mkl? ( sci-libs/mkl )
+"
+
+python_prepare_all() {
+ # TODO: mkl can be used but it fails for me
+ # only works with mkl in tree. newer mkl will use pkgconfig
+ if use mkl; then
+ use amd64 && local ext="_lp64"
+ cat > site.cfg <<- _EOF_ || die
+ [mkl]
+ library_dirs = ${MKLROOT}/lib/em64t
+ include_dirs = ${MKLROOT}/include
+ mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
+ mkl_intel_thread, mkl_core, iomp5
+ _EOF_
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pushd "${BUILD_DIR}"/lib >/dev/null || die
+ "${EPYTHON}" \
+ -c "import sys,numexpr; sys.exit(0 if numexpr.test().wasSuccessful() else 1)" \
+ || die
+ pushd >/dev/null || die
+}