summaryrefslogtreecommitdiff
path: root/dev-python/nuitka
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/nuitka
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/nuitka')
-rw-r--r--dev-python/nuitka/Manifest3
-rw-r--r--dev-python/nuitka/metadata.xml26
-rw-r--r--dev-python/nuitka/nuitka-2.5.1.ebuild55
3 files changed, 84 insertions, 0 deletions
diff --git a/dev-python/nuitka/Manifest b/dev-python/nuitka/Manifest
new file mode 100644
index 000000000000..0b3722f6a170
--- /dev/null
+++ b/dev-python/nuitka/Manifest
@@ -0,0 +1,3 @@
+DIST Nuitka-2.5.1.tar.gz 3776847 BLAKE2B a6c36e736cf8aaa830cb5a47a2ae9ea9394c2afb5163e7955c196fb9ee9c37c61edc085c65f258bac0e27468bd97e5fb93bdeb8776fee85b99fd8c45076166b6 SHA512 ddf86589e2e576ae79b4e88fecac0668ef8e8c720d79d83799a15647c664c0d026f1241bcbc29036fab821611079ae808c22cb81ef14781bc7d0f96c3dba0428
+EBUILD nuitka-2.5.1.ebuild 1222 BLAKE2B 172c3dfa35f912ae359c41bd5176ef8ce85b17c24169599e787225f62ebd8a906939e7a8666cab9727cd70358caa8596e9cdc677e1303d7f392511d40446bc35 SHA512 788d25cfe72f025177db6d79d7ea66918e6b1eb4fb2670aa12488e278e9079ec854060067f18599d2b5729297dd5d9e259c230124b8c915639c6881cec10a250
+MISC metadata.xml 943 BLAKE2B d7ab883773e7480dcfb4b79932a3874e2274669169a24a54aa622a2a0ac079e0296da4bd196d166cb11fcff785985da0b10d0fae351032914ccf312c9bb9833c SHA512 625d8760b8e849c6e014856f584cb42f50bb5ebb1fa648cb704a5a1baf175e7d2ce9f43f6f724d11c81a68e364b6ac1c38459540b58f2ccd6a675902af5b1cc9
diff --git a/dev-python/nuitka/metadata.xml b/dev-python/nuitka/metadata.xml
new file mode 100644
index 000000000000..465fe958dc3b
--- /dev/null
+++ b/dev-python/nuitka/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <name>Oz Tiram</name>
+ <email>oz.tiram@gmail.com</email>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Python compiler with full language support and CPython compatibility
+ This Python compiler achieves full language compatibility and compiles Python
+ code into compiled objects that are not second class at all. Instead they can
+ be used in the same way as pure Python objects.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">Nuitka/Nuitka</remote-id>
+ <remote-id type="pypi">Nuitka</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nuitka/nuitka-2.5.1.ebuild b/dev-python/nuitka/nuitka-2.5.1.ebuild
new file mode 100644
index 000000000000..d79d86fa299c
--- /dev/null
+++ b/dev-python/nuitka/nuitka-2.5.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN^}
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 flag-o-matic optfeature pypi
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="
+ https://nuitka.net/
+ https://github.com/Nuitka/Nuitka/
+ https://pypi.org/project/Nuitka/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-build/scons[${PYTHON_USEDEP}]
+ >=dev-python/ordered-set-4.1.0[${PYTHON_USEDEP}]
+ >=dev-python/zstandard-0.15[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "nuitka/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka.1 doc/nuitka-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" dev-util/patchelf
+}