summaryrefslogtreecommitdiff
path: root/dev-python/nuitka/nuitka-1.0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-27 20:54:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-27 20:54:43 +0100
commitdab4468820bf30b5a0764b19f519006f0e6bb371 (patch)
tree81b0d4daac1676804b504ed5c49a833b334d1024 /dev-python/nuitka/nuitka-1.0.6.ebuild
parentd654bb059f90c086625a31ce15747f8418cd4bd5 (diff)
gentoo auto-resync : 27:08:2022 - 20:54:42
Diffstat (limited to 'dev-python/nuitka/nuitka-1.0.6.ebuild')
-rw-r--r--dev-python/nuitka/nuitka-1.0.6.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/nuitka/nuitka-1.0.6.ebuild b/dev-python/nuitka/nuitka-1.0.6.ebuild
new file mode 100644
index 000000000000..5b987e13729d
--- /dev/null
+++ b/dev-python/nuitka/nuitka-1.0.6.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 flag-o-matic optfeature
+
+DESCRIPTION="Python to native compiler"
+HOMEPAGE="https://www.nuitka.net"
+SRC_URI="https://nuitka.net/releases/${P^}.tar.gz"
+S="${WORKDIR}/${P^}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-util/scons[${PYTHON_USEDEP}]"
+BDEPEND="
+ ${RDEPEND}
+ test? ( dev-util/ccache )
+"
+
+DOCS=( Changelog.pdf Developer_Manual.pdf README.pdf )
+
+distutils-r1_src_prepare() {
+ # remove vendored version of SCons that is Python2 only
+ # this should be removed when upstream removes support for Python2
+ rm -vR "${PN}/build/inline_copy/lib/scons-2.3.2/SCons" || die
+ eapply_user
+}
+
+python_install() {
+ distutils-r1_python_install
+ doman doc/nuitka3.1 doc/nuitka3-run.1
+}
+
+python_test() {
+ append-ldflags -Wl,--no-warn-search-mismatch
+ ./tests/basics/run_all.py search || die
+}
+
+pkg_postinst() {
+ optfeature "support for stand-alone executables" app-admin/chrpath
+}