summaryrefslogtreecommitdiff
path: root/dev-python/ntlm-auth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-10 05:25:01 +0000
commit456dbeaab3e2f71f527eae542ab44d1e372b0655 (patch)
tree5cee708ec6e4b4e530a4337e7389598dc7cd6144 /dev-python/ntlm-auth
parent65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (diff)
gentoo resync : 10.01.2018
Diffstat (limited to 'dev-python/ntlm-auth')
-rw-r--r--dev-python/ntlm-auth/Manifest3
-rw-r--r--dev-python/ntlm-auth/metadata.xml15
-rw-r--r--dev-python/ntlm-auth/ntlm-auth-1.0.6.ebuild21
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/ntlm-auth/Manifest b/dev-python/ntlm-auth/Manifest
new file mode 100644
index 000000000000..a8e3be38e3d8
--- /dev/null
+++ b/dev-python/ntlm-auth/Manifest
@@ -0,0 +1,3 @@
+DIST ntlm-auth-1.0.6.tar.gz 48282 BLAKE2B 988634d78d6c30a92791baaf4dff865fe2bba8318ce1bcd9739c267d11fb29ae90e7b0348b05b4ef3754cf20675aa690973cca03fa35c195ae0c73c6ac6120e8 SHA512 e6abafd52affebfe0f60ed1fd77543dbfe675a82774bffc44d2e034226806ce6781adc5ca8ac29c35c6fe75440f94a1763e01b0987669cb44a6fe01e102a1489
+EBUILD ntlm-auth-1.0.6.ebuild 565 BLAKE2B 285d06d921e3cb8fe5c91a1b9782e0d5e22c87ddd14140832dc1e1e70eb871f1222ddf89f27910a5845273840147f51dd2c760b9f4d6be4c5d513bc2a5d8422e SHA512 9d35c2f83b1c5ae9e0b07fd8552eb74af4096371ffb10da32e16407b33652e2ce176439229c1329bd2840148730be10a7c7e679aa085f2a721465526d60223e7
+MISC metadata.xml 425 BLAKE2B 791b65f110ff47908b2ada3e140cbd1fb262f0cce02e5ac083cb4fecbfba686a44aece6a3d44a69b6876c4603dd74d343fd9a61638f908836250bf3badeb9524 SHA512 a38de76267e3e44d11a8e3571809031b94697d270e3c752629764300893e95ccb1e8daf8a9bf897a442fb3b097fd6da4f3d4d34fbaead847474335a53ab91768
diff --git a/dev-python/ntlm-auth/metadata.xml b/dev-python/ntlm-auth/metadata.xml
new file mode 100644
index 000000000000..68bde49cc71f
--- /dev/null
+++ b/dev-python/ntlm-auth/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">ntlm-auth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/ntlm-auth/ntlm-auth-1.0.6.ebuild b/dev-python/ntlm-auth/ntlm-auth-1.0.6.ebuild
new file mode 100644
index 000000000000..54b600d8ff15
--- /dev/null
+++ b/dev-python/ntlm-auth/ntlm-auth-1.0.6.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Calculates NTLM Authentication codes"
+HOMEPAGE="https://github.com/jborean93/ntlm-auth"
+SRC_URI="https://github.com/jborean93/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/ordereddict[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}"