summaryrefslogtreecommitdiff
path: root/dev-python/nspektr
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/nspektr
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/nspektr')
-rw-r--r--dev-python/nspektr/Manifest2
-rw-r--r--dev-python/nspektr/nspektr-0.4.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/nspektr/Manifest b/dev-python/nspektr/Manifest
index 6b09b33f1086..c42ddcc8bd04 100644
--- a/dev-python/nspektr/Manifest
+++ b/dev-python/nspektr/Manifest
@@ -1,3 +1,5 @@
DIST nspektr-0.3.0.tar.gz 6314 BLAKE2B cb7b9b5b35a455d4e72e78d93db49b4f8e274c7d7a6c8bf7ccca52cce2598a937d31b76f1a30c4aa6d673e4ce52c4645ce7392965df35b0888d1c69226e08f00 SHA512 6fc22ad7858858f3b956ba5918ca92468f13d4b7db0e4861b836e63153f7e4319c6468e4f73969ce3fb7845ca8d97808b9db2eb2705a47fe1a8c4c19b9c2ef33
+DIST nspektr-0.4.0.gh.tar.gz 6763 BLAKE2B 6393a2d16825cbd580758ba09a7f2277417fc0eb4e7c6f23d49ff1af89a7c6947d4c0bae7158424b96f8f0e3e3aab6ac3f5bb624a8d7edf61eb571b28e690d70 SHA512 c106091e949ce8236c1cf54543bebd2b63484dff95e161fb57668bd6bcb4b17ddf0ecc440c15a0df36cc8c4398ccc439b642eab49b528ba2cbedc75ff009179d
EBUILD nspektr-0.3.0.ebuild 1743 BLAKE2B f455eb064a5e15d5a2162da586148a4a8568a7f8e951407d32b4dd3211435d1ee4ab8021f33d9e7938058e1637455ba1744211796862854842bf2e44a956aa9f SHA512 4d2875ebd1004be37d1b2ae1c5825fe137532b96ab942f8912868e5eea4434b1d0091003831428a9a9d907c69198760b5ac5ab8221d7b1697de30e1e53ff2199
+EBUILD nspektr-0.4.0.ebuild 1618 BLAKE2B 9657cc0d10ead056c40be7bf7b03da0713dcb11c025a5da648c0030794a93b3782741a912cc342a14675a46b7c4a6cf5f3331ae8255d76a70b24d05570d62125 SHA512 96f935b20516268627ec925bf4ce4264833befaeeeb7ab7b8f0aa5edaf21886625f4ff39fe66a2de66182efdb4709d23d076b91f95f6146b308aaeb92d95a771
MISC metadata.xml 343 BLAKE2B c5ec4b6c1f41692875fcb9a93dea4c0f253339788b94fd667709898e2cc49470f113258137093fd29986ed8fbadf2ea64f95319c51568f12259b8869558bfdab SHA512 da052d5ee619430fbfc021b9eb8d3967dc4d6ca3ce0bc5c9b1badb067d7c0babe12abde3fbc9c4710bc6a0cf081e6bc445504b852ec714f819781e1c4780779a
diff --git a/dev-python/nspektr/nspektr-0.4.0.ebuild b/dev-python/nspektr/nspektr-0.4.0.ebuild
new file mode 100644
index 000000000000..832fd4c23343
--- /dev/null
+++ b/dev-python/nspektr/nspektr-0.4.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
+EAPI=7
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distribution package dependency inspector"
+HOMEPAGE="
+ https://github.com/jaraco/nspektr/
+ https://pypi.org/project/nspektr/
+"
+SRC_URI="
+ https://github.com/jaraco/nspektr/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-python/jaraco-context-4.1.1-r2[${PYTHON_USEDEP}]
+ >=dev-python/jaraco-functools-3.5.0-r2[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-8.12.0-r1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3-r2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib_metadata-4.11.2[${PYTHON_USEDEP}]
+ ' 3.8 3.9)
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ grep -q 'build-backend = "setuptools' pyproject.toml ||
+ die "Upstream changed build-backend, recheck"
+ # write a custom pyproject.toml to ease setuptools bootstrap
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["flit_core >=3.2,<4"]
+ build-backend = "flit_core.buildapi"
+
+ [project]
+ name = "nspektr"
+ version = "${PV}"
+ description = "package inspector"
+
+ # tests inspect itself
+ [project.optional-dependencies]
+ docs = [
+ "fake-nonexisting",
+ ]
+ testing = [
+ "pytest",
+ ]
+ EOF
+}