summaryrefslogtreecommitdiff
path: root/dev-python/nox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-04 11:43:04 +0000
commit56a597689e7509193b0924a635d2022f21b1a3e4 (patch)
tree476358a5cea634edc1fb0504f6ec03b282cfb83e /dev-python/nox
parent57e2174dcd454b41778b7b437f88d0a9f1a6e428 (diff)
gentoo auto-resync : 04:03:2024 - 11:43:04
Diffstat (limited to 'dev-python/nox')
-rw-r--r--dev-python/nox/Manifest2
-rw-r--r--dev-python/nox/nox-2024.03.02.ebuild64
2 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/nox/Manifest b/dev-python/nox/Manifest
index a250fc347558..6b40e8472e2d 100644
--- a/dev-python/nox/Manifest
+++ b/dev-python/nox/Manifest
@@ -1,3 +1,5 @@
DIST nox-2023.04.22.gh.tar.gz 3985377 BLAKE2B 7365141bf1c299f6e560dbf42a2927f98e5bf7121ed0dc1dbdc739de847caafdc0834fdc2f2473f20b97d25a4d1d01aced8400e85ec6c027494b8d93077d9a0b SHA512 7425588b0ae87d66211a4fec1d204122a2adb114ddca866d2e66e1caff930f593af1540e5c88806894400ea8aba92037d3f458a98df05d6ac70662705426ee6e
+DIST nox-2024.03.02.gh.tar.gz 3995248 BLAKE2B 3dc1ad8764fb1f849d15b7613999e2a9480f4b072d1b3ceb1d4316a8a97eaad418dc0d151b5477bf807e0f8b983fd53ca73a29cae3faed4f93a015f5b1d253ad SHA512 7b76d62ced6d6968fab489223fbe2af1270b19fe2f2376c2fef375c47ca1bce7de23a5686b7c8dc617cb0cd331a90b9806bf3b478c28e61294aa4ea453635dcb
EBUILD nox-2023.04.22.ebuild 1079 BLAKE2B d0fdc6a53a5faa6f997f0d066747e4075b1d5a9339ebd1321a9029bb81b7dcccb3ea8779ae44d32438a2174530e429eaf342ba4a3b8ef34410209ddb9f5d5dd6 SHA512 36b37041d051d175723f079b314a8b2481b3e529b06e3f508e636d961e3590a806c356deff3adc9cca825456a8527de2efeea45249584c7fc8d5b3055e97222b
+EBUILD nox-2024.03.02.ebuild 1420 BLAKE2B 913082b8fd7af086bc80fc9828f029ceefbe14d5486f86c9701cf4a660336f0b659ab3d24ba6bc40686cc99d428ce36f61f6075be06fb50edf075542fffc6cd7 SHA512 673426070c4dbbcd32f5a91ff0aba992d3bbd1c60ed39598ce34662cbef3971fbc95b4aa8e72fd49d00710709a14f5c42ae5db53814b1eb3537881a83f65dfb3
MISC metadata.xml 382 BLAKE2B 52bcdba99198ee70c06bcb2d118ae3d92f3072ad7df91433670b6ba14ca76489dac5b275780d11b1052e19a1c03d5021f42ba75c3d5e236f1e028c54f19129c2 SHA512 9fb9741a9920cc7537180b07f2715e40b058c5fd18b74e030c0cc598a46dc5a72b227982a11e39fc09dfe200b3cff0a4c150436709c86cb6e44508e412d364b7
diff --git a/dev-python/nox/nox-2024.03.02.ebuild b/dev-python/nox/nox-2024.03.02.ebuild
new file mode 100644
index 000000000000..a6a145b1df10
--- /dev/null
+++ b/dev-python/nox/nox-2024.03.02.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Flexible test automation for Python"
+HOMEPAGE="
+ https://github.com/wntrblm/nox/
+ https://pypi.org/project/nox/
+"
+SRC_URI="
+ https://github.com/wntrblm/nox/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ >=dev-python/argcomplete-1.9.4[${PYTHON_USEDEP}]
+ >=dev-python/colorlog-2.6.1[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.9[${PYTHON_USEDEP}]
+ >=dev-python/virtualenv-20.14.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/py[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # remove upper bounds from dependencies
+ sed -i -e 's:<[0-9.]*,::' pyproject.toml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # TODO: conda?
+ 'tests/test_sessions.py::TestSessionRunner::test__create_venv_options[nox.virtualenv.CondaEnv.create-conda-CondaEnv]'
+ )
+
+ case ${EPYTHON} in
+ pypy3)
+ EPYTEST_DESELECT+=(
+ # hardcoded CPython assumption
+ tests/test_tox_to_nox.py::test_skipinstall
+ tests/test_tox_to_nox.py::test_trivial
+ tests/test_tox_to_nox.py::test_usedevelop
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o tmp_path_retention_policy=all
+}