summaryrefslogtreecommitdiff
path: root/dev-python/notify2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/notify2
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/Manifest1
-rw-r--r--dev-python/notify2/notify2-0.3.1-r3.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
index 18ae67fec218..74058fd0f106 100644
--- a/dev-python/notify2/Manifest
+++ b/dev-python/notify2/Manifest
@@ -1,3 +1,4 @@
DIST notify2-0.3.1.tar.gz 17792 BLAKE2B 649df1934d1fffb97dabbf2f483204c55427fbede851840d642da2e4e62a9bda9d49670e60f5b2cda36b62ee47b7d0cd861d757d338867547dce3c7d61ddf7b4 SHA512 0b69a64e0a7e4955ee767c975db92c5c60d28c0e54f77498cfb98390771a8f536631fc34e42b5c46c138dfa1054b5516a0809b8e3b0cb9237a39825ddb827109
EBUILD notify2-0.3.1-r2.ebuild 857 BLAKE2B 0f99a3ee46a04f85f5fe67d2d0d01dfd5669b5a626f43720a4f70c318f17373296a7d2b34c52d1e5a8d45e5d7c05f773e59955322e4e56ab4649333006da0fa4 SHA512 2548f4bfbfb8e68954e715f5d70669a5480e509c10062d32fb5888d4cca14ab00271fa65fbb202a989522dd555a0ab61587441ec324c51de52558871386488d8
+EBUILD notify2-0.3.1-r3.ebuild 858 BLAKE2B 5b32b0a22efa19614b35cc086d906e775b6649c04f66a42ecbc45c70349bfcd2ba89472eae432fd4ecea516594008136cce4d48201e4bf4a13142aa93c6f08d3 SHA512 72ba016b3758a18185c458373f72240855dd192aaae65701e73671706fbc9e3a3550bdd46a833ec015f74e3f2eefa767cc4f85c5919726c653c80cc006014311
MISC metadata.xml 490 BLAKE2B 7627e5eb7c44257e2d495d2fc86e455e88eebe9a6d9a02491580b558224549bb9f93cfcb2f623375006537826599e81e8a2c5bb844930dee2381c40182cb3fcf SHA512 159eb84765ef2e160b602cb8725364c0e15efd3f42f6939643e38f271d1a5bc3ff610b24bc775cbd8a189faa796cda4652537ee19ab4678c805c7a90b11e1478
diff --git a/dev-python/notify2/notify2-0.3.1-r3.ebuild b/dev-python/notify2/notify2-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..18e4358229b8
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.1-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Python interface to DBus notifications"
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+BDEPEND="test? (
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ x11-libs/gdk-pixbuf[introspection]
+ virtual/notification-daemon
+)"
+
+distutils_enable_tests unittest
+
+python_test() {
+ virtx eunittest
+}
+
+python_install_all() {
+ if use examples; then
+ rm examples/notify2.py || die
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}