summaryrefslogtreecommitdiff
path: root/dev-python/notify2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /dev-python/notify2
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/Manifest2
-rw-r--r--dev-python/notify2/notify2-0.3.1-r2.ebuild17
2 files changed, 13 insertions, 6 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
index 2d58f7370f32..425d68c78599 100644
--- a/dev-python/notify2/Manifest
+++ b/dev-python/notify2/Manifest
@@ -1,3 +1,3 @@
DIST notify2-0.3.1.tar.gz 17792 BLAKE2B 649df1934d1fffb97dabbf2f483204c55427fbede851840d642da2e4e62a9bda9d49670e60f5b2cda36b62ee47b7d0cd861d757d338867547dce3c7d61ddf7b4 SHA512 0b69a64e0a7e4955ee767c975db92c5c60d28c0e54f77498cfb98390771a8f536631fc34e42b5c46c138dfa1054b5516a0809b8e3b0cb9237a39825ddb827109
-EBUILD notify2-0.3.1-r2.ebuild 726 BLAKE2B df82bcc43b12585b69c230fe96a9972a844942529aa9e60203f6e7df0722c3ece0dd19160d575557a0bcd6590398349270e8c9801dff9088783e8d7de6c355c6 SHA512 09204dfd6ac52dc9c9c02c52f53da93a48c66460f6cd5dc90a4ccdbfba64c651ea1914dc45f06d352807e915b56c473d1db3e040ff18570bcdf0e885bf317fae
+EBUILD notify2-0.3.1-r2.ebuild 858 BLAKE2B 334db2c0fb768c754debbd7b4723384db1bace49e44ae798029263a30c6808b98a58bd283b44e95d84193214c7859b5ad74f274aa990c2464427167ccc8ef124 SHA512 7739d87f8438ca05bf1d52313e9a15187609d017262288dcdd0792ead3e669cf5351dba6a284c15d4ae5a164743c39aacf784b3ac618fef30d515611a528b488
MISC metadata.xml 490 BLAKE2B 7627e5eb7c44257e2d495d2fc86e455e88eebe9a6d9a02491580b558224549bb9f93cfcb2f623375006537826599e81e8a2c5bb844930dee2381c40182cb3fcf SHA512 159eb84765ef2e160b602cb8725364c0e15efd3f42f6939643e38f271d1a5bc3ff610b24bc775cbd8a189faa796cda4652537ee19ab4678c805c7a90b11e1478
diff --git a/dev-python/notify2/notify2-0.3.1-r2.ebuild b/dev-python/notify2/notify2-0.3.1-r2.ebuild
index 707efcbff8b2..d21b0ee686bf 100644
--- a/dev-python/notify2/notify2-0.3.1-r2.ebuild
+++ b/dev-python/notify2/notify2-0.3.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1 virtualx
@@ -18,10 +18,17 @@ KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
IUSE="examples"
RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
-DEPEND="test? ( sys-apps/dbus[X] )"
+BDEPEND="test? (
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ x11-libs/gdk-pixbuf[introspection]
+ virtual/notification-daemon
+)"
-python_test() {
- virtx ${EPYTHON} test_notify2.py
+distutils_enable_tests unittest
+
+src_test() {
+ virtx distutils-r1_src_test
}
python_install_all() {