summaryrefslogtreecommitdiff
path: root/dev-python/notify2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/notify2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/notify2')
-rw-r--r--dev-python/notify2/Manifest3
-rw-r--r--dev-python/notify2/metadata.xml15
-rw-r--r--dev-python/notify2/notify2-0.3.ebuild30
3 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/notify2/Manifest b/dev-python/notify2/Manifest
new file mode 100644
index 000000000000..fc82e19b6ae4
--- /dev/null
+++ b/dev-python/notify2/Manifest
@@ -0,0 +1,3 @@
+DIST notify2-0.3.tar.gz 8798 BLAKE2B 57e1eeaa96b9e5354991db36440abfbf80471887c094e41dd6ccff72f1b1b35524bebf83b44afa455c64cdc3fb7b0ef66d2517ca499340a3d001e796828ff9b6 SHA512 3290a5ff291d5500bcf631094fcf10302b234353eb8c26b91e7cd264238443866aadc15224d51eb6608e16b7ffbc9316d4bc551e5ad9de2a48b12a31b195739f
+EBUILD notify2-0.3.ebuild 653 BLAKE2B b9f9362db64a230f7f8e6ad2c2d7fae00842d7327cefbb287d01acc0cd919111a9d1c76c79df71fcdebe747071430fb39506a94e667b2f23f180f0c78c454b6a SHA512 f278fcf00bd29146f4c09e717a7ec102f363c3b1db1ae87a2a6c07e1efc75adde1c3611578de0c4b41598714ee327723aa13c1773c7f502704b2a08a996ef49f
+MISC metadata.xml 465 BLAKE2B 477ef3b148c7916372b0c12fc450dc9bacb59c609a3e3e005be6f8d5a268661405744c16180b336e34f4782f7e3a38ba17e63747d46199d0eb161e23d8415eaa SHA512 8024b5c580d09b74bf6a258dad507bec09d0c7bbbd10861bc2f866dd71acd7a858e7175dcb1d670cfdbade64da3f607667434a8587de6ceaeee7da028ce332ba
diff --git a/dev-python/notify2/metadata.xml b/dev-python/notify2/metadata.xml
new file mode 100644
index 000000000000..f05b38bba4f5
--- /dev/null
+++ b/dev-python/notify2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="bitbucket">takluyver/pynotify2</remote-id>
+ <remote-id type="pypi">notify2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/notify2/notify2-0.3.ebuild b/dev-python/notify2/notify2-0.3.ebuild
new file mode 100644
index 000000000000..a36960451652
--- /dev/null
+++ b/dev-python/notify2/notify2-0.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to DBus notifications."
+HOMEPAGE="https://bitbucket.org/takluyver/pynotify2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/dbus-python[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${EPYTHON} test_notify2.py || die
+}
+
+python_install_all() {
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*
+ fi
+ distutils-r1_python_install_all
+}