summaryrefslogtreecommitdiff
path: root/dev-python/notebook-shim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-28 05:11:40 +0100
commit2099ff9b640e648be67527e29760263a7c6274e5 (patch)
tree238358af0ba45fd8fcc6cd4679736d6c4f07f851 /dev-python/notebook-shim
parentd198e0ebeee70707545d19ee3beb1de70802cc7c (diff)
gentoo auto-resync : 28:04:2023 - 05:11:40
Diffstat (limited to 'dev-python/notebook-shim')
-rw-r--r--dev-python/notebook-shim/Manifest5
-rw-r--r--dev-python/notebook-shim/metadata.xml17
-rw-r--r--dev-python/notebook-shim/notebook-shim-0.2.2-r1.ebuild43
-rw-r--r--dev-python/notebook-shim/notebook-shim-0.2.3.ebuild44
4 files changed, 109 insertions, 0 deletions
diff --git a/dev-python/notebook-shim/Manifest b/dev-python/notebook-shim/Manifest
new file mode 100644
index 000000000000..f8ad8329fca1
--- /dev/null
+++ b/dev-python/notebook-shim/Manifest
@@ -0,0 +1,5 @@
+DIST notebook_shim-0.2.2.tar.gz 12947 BLAKE2B 5a04944be3f8de7bd7b1c10f59d73869b7aed670c3afebf79e7780d5992f9af2929529498604c1a5c0d164467681ffa0e8924e1c9a7945e52ae353bdb710c7bc SHA512 42cf9153495e4ab8230ef560d36381a5aa1d9bbd583ed140e04e9850f4a82bab06ecf36e45b88595e8686d8122c9a52eee8133a7f1b622d75d326ebf36519d30
+DIST notebook_shim-0.2.3.tar.gz 13082 BLAKE2B 5e988605ee01a49f31bf2dcdbe86d2f8e12f3e314d962f619068c57b13ed144643db1b08d5afed7a91ddfcde82497e49fe643d9fdd1c43a9535d7468794dfe7e SHA512 87114ea915ab5160b11023dddcc622aafba315fe07de21cedbed1e374ec2406eba378575e903377dbb9cc69e7449eb184cb0420513b7dc05078af0e91bc5f884
+EBUILD notebook-shim-0.2.2-r1.ebuild 936 BLAKE2B a75727e454425383a84283216e6b0df9c2f7e2cbbc39fc688622fee24f48979aed83c779b3a595e222470044518103483def186308f81b960741b652e5a4f845 SHA512 3580cf9a8b6f3a346102759ad0e371e88b64312b90a781839060c1fd9f33352bbad36fa02284521182cd91bcc81c3487c311131113a758fc6a1b1a28dea72724
+EBUILD notebook-shim-0.2.3.ebuild 937 BLAKE2B a164f213747820ae08131244e0b734c6b4568204195c9ccb4b5380762e6770660475713eb7d14c1249b3f33f7306d3161a50716eda58e8b3bd6f812e53010f68 SHA512 a67f38dc93383b88bdb2449c0321594640acfeac79aa9d632e1f123f87c555b5c88416b71ffea41bbe2b4849e38562397bf8c9828c790c31137d373fb95bebbc
+MISC metadata.xml 535 BLAKE2B 074e2bbcdd15078aaba2c65641a16ca7ce27e0c412d48f2a48a4cd80459a948abc478baa28b3e7417dde2bf13717040dc083711b114d61dfd2a7f7aaac1295ca SHA512 9ff7408848878f74eb9f10ec5aded639a749635851385b6679a72112c253a7427f65ac3e3c41f21f9e8551a439a7c00c4e28a5d70b3529ab9e687a5d0e7abeb9
diff --git a/dev-python/notebook-shim/metadata.xml b/dev-python/notebook-shim/metadata.xml
new file mode 100644
index 000000000000..7093f58896b9
--- /dev/null
+++ b/dev-python/notebook-shim/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">notebook-shim</remote-id>
+ <remote-id type="github">jupyter/notebook_shim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/notebook-shim/notebook-shim-0.2.2-r1.ebuild b/dev-python/notebook-shim/notebook-shim-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..146916c5c88b
--- /dev/null
+++ b/dev-python/notebook-shim/notebook-shim-0.2.2-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=hatchling
+inherit distutils-r1 pypi
+
+DESCRIPTION="A shim layer for notebook traits and config"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/notebook_shim/
+ https://pypi.org/project/notebook-shim/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}
diff --git a/dev-python/notebook-shim/notebook-shim-0.2.3.ebuild b/dev-python/notebook-shim/notebook-shim-0.2.3.ebuild
new file mode 100644
index 000000000000..7e177997b7f2
--- /dev/null
+++ b/dev-python/notebook-shim/notebook-shim-0.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A shim layer for notebook traits and config"
+HOMEPAGE="
+ https://jupyter.org/
+ https://github.com/jupyter/notebook_shim/
+ https://pypi.org/project/notebook-shim/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/jupyter-server-3[${PYTHON_USEDEP}]
+ >=dev-python/jupyter-server-1.8[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-tornasync[${PYTHON_USEDEP}]
+ dev-python/pytest-jupyter[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_tornasync.plugin
+}
+
+src_install() {
+ distutils-r1_src_install
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}