summaryrefslogtreecommitdiff
path: root/dev-python/nosehtmloutput
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/nosehtmloutput
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/nosehtmloutput')
-rw-r--r--dev-python/nosehtmloutput/Manifest3
-rw-r--r--dev-python/nosehtmloutput/metadata.xml19
-rw-r--r--dev-python/nosehtmloutput/nosehtmloutput-0.0.5.ebuild20
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/nosehtmloutput/Manifest b/dev-python/nosehtmloutput/Manifest
new file mode 100644
index 000000000000..91100e17f155
--- /dev/null
+++ b/dev-python/nosehtmloutput/Manifest
@@ -0,0 +1,3 @@
+DIST nosehtmloutput-0.0.5.tar.gz 7525 BLAKE2B 3beb983be772d51a13be64879970b2457387002a641b440ac7287aad2343134eb94254855f240f4937be4f9bb59156c14ef7c872b55896f35191a8114cb5c025 SHA512 85bf7d2ab9db9e054772a1af85c17b6213edb2c5bcf30e78392470ad79fad51f15a67f5923282b867248828beab4ca5ea57fe18a071c21995cf56cb56c6bec84
+EBUILD nosehtmloutput-0.0.5.ebuild 540 BLAKE2B def5749e7d47e32b749d64047c83ac5e9d34520aae072d9be97003934121f301ebb0c834c08efd3bec4d2f5c99de8d9ecc1eef87c7326cfe7a696d9ecd45e926 SHA512 0874e04869aa48b1a2d759623c80ce8a72a285511a441fdb19243b3e15831f065f87f6c291036ea7a0e56d952d8b36beba14540ee3e5cd1942fed2f0e937af4e
+MISC metadata.xml 614 BLAKE2B 1aeacecf30cd90b8c0146f30cf09c1958c84852ef8d3a3fe67b30e5cd9e25dcfd6b877563ef6e1cfad92b43f2224155c1b74c8da5fa7717be63a21990d4e5499 SHA512 5b48dfcbfb6dee148d81cb829ff30f90f7717d509e94e346668fabaf61bcef52dddd831ebb4adb29d8ea4593dc8364ec8d623742e14a7702fe4024f9bd92a601
diff --git a/dev-python/nosehtmloutput/metadata.xml b/dev-python/nosehtmloutput/metadata.xml
new file mode 100644
index 000000000000..f6206cc06be4
--- /dev/null
+++ b/dev-python/nosehtmloutput/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Nose plugin to produce test results in html.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">nosehtmloutput</remote-id>
+ <remote-id type="github">cboylan/nose-html-output</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/nosehtmloutput/nosehtmloutput-0.0.5.ebuild b/dev-python/nosehtmloutput/nosehtmloutput-0.0.5.ebuild
new file mode 100644
index 000000000000..8139e72c7c0b
--- /dev/null
+++ b/dev-python/nosehtmloutput/nosehtmloutput-0.0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Nose plugin to produce test results in html"
+HOMEPAGE="https://github.com/cboylan/nose-html-output"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"