summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /dev-python/nose
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/Manifest1
-rw-r--r--dev-python/nose/nose-1.3.7-r7.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/nose/Manifest b/dev-python/nose/Manifest
index 04e40a5ba14c..f27fa25f6987 100644
--- a/dev-python/nose/Manifest
+++ b/dev-python/nose/Manifest
@@ -3,4 +3,5 @@ AUX nose-1.3.7-python-3.5-backport.patch 1802 BLAKE2B 8513cd506f7031ec4af1a4acd6
AUX nose-1.3.7-python-3.6-test.patch 3289 BLAKE2B 4f19c4f6e4f376cb09896f9e7b054753c339ad371e151f01cc8c54e83ecffee72e4959d827a88d03b4944192b43085b50017ef8b8785222125ce32fac5831717 SHA512 0be6e49f08a4098b4c5dd1d9678e757c8f1f317fb13bd355a035c44bcdd9cd043be1755bb97c4ca78397985f07f6fc486ddd10cb56dd8d8774d631eebcc81127
DIST nose-1.3.7.tar.gz 280488 BLAKE2B 4bb479b2786f813f9e9a5fd401e30023a473a053ae013d7887be15af415422c09fb399af6058ae99ed65c5fa4da84eb274eb805e895ca74db159d952905f5be4 SHA512 e65c914f621f8da06b9ab11a0ff2763d6e29b82ce2aaed56da0e3773dc899d9deb1f20015789d44c65a5dad7214520f5b659b3f8d7695fb207ad3f78e5cf1b62
EBUILD nose-1.3.7-r6.ebuild 2376 BLAKE2B 805a479082b87865e782f5de72ad024ddca3bde297cfa7d667a98ca36d395b343c0161defad74f35630b0c94a55f7594ab2df89f045919fb487ab16c1ddef672 SHA512 b930ea4730f8c6095ffe018810a42f9aaf316af9c9b93f61765dcf2a193bd595b17698ddb4d87c00ab0335d49817a8df8ad15f66c870085e046d9418f0d36869
+EBUILD nose-1.3.7-r7.ebuild 2303 BLAKE2B d5903baa2d1e645152220149d6fb06c5b765a426c1b679162bc38c4187fd3a42a8cf9b35196db734644271dda438c523e46f5c737ce79f0a0fb189dfa1b9e323 SHA512 4b1c0a40cd9cbe7bfa4c0fe1416fff644388d9460c6a5ce4df96ea74977cf90ea16140aada6b6c498268eb93ba2c39cdc9964c45bcb011ac7b2a9039a0329c17
MISC metadata.xml 524 BLAKE2B 90a98bae0d27a49c51aee677f8bdebcbee461d74fad0f349f73458229098ba3038705d63a88c59f90ef8621931e5d3902c0209bd627c28d2b0296deaff4af75d SHA512 4dc9346469b9b3a0b87fffe49db530107a019bd798fba0620b671d71a43805537face8451c24d6ad40bf11ed3498d8970ddc1ce3109398534c9f3c8ed72743e0
diff --git a/dev-python/nose/nose-1.3.7-r7.ebuild b/dev-python/nose/nose-1.3.7-r7.ebuild
new file mode 100644
index 000000000000..f72c21ba2527
--- /dev/null
+++ b/dev-python/nose/nose-1.3.7-r7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+ https://pypi.org/project/nose/
+ https://nose.readthedocs.io/en/latest/
+ https://github.com/nose-devs/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="coverage examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ coverage? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/twisted[${PYTHON_USEDEP}]
+ ' 'python3*')
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.5-backport.patch
+
+ # Patch against master found in an upstream PR, backported:
+ # https://github.com/nose-devs/nose/pull/1004
+ "${FILESDIR}"/${P}-coverage-4.1-support.patch
+
+ "${FILESDIR}"/${P}-python-3.6-test.patch
+)
+
+python_prepare_all() {
+ # Tests need to be converted, and they don't respect BUILD_DIR.
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+ -i setup.py || die "sed2 failed"
+
+ # fix manpage install path
+ sed -i -e 's:man/:share/&:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local add_targets=()
+
+ if use test; then
+ add_targets+=( egg_info )
+ python_is_python3 && add_targets+=( build_tests )
+ fi
+
+ distutils-r1_python_compile "${add_targets[@]}"
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}