summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-07 01:33:16 +0100
commitc8fd0d84af0bfd1949542adc2cbb735b1d28f9ed (patch)
tree3ee550255947da075650f1a551dcc278f9a1b7f8 /dev-python/nose
parenta978c074e4272bb901fbe4a10de0a7b2af574f17 (diff)
gentoo resync : 07.05.2021
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/Manifest1
-rw-r--r--dev-python/nose/nose-1.3.7-r8.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/nose/Manifest b/dev-python/nose/Manifest
index c1e6918d00bf..5a35ca7f8387 100644
--- a/dev-python/nose/Manifest
+++ b/dev-python/nose/Manifest
@@ -3,4 +3,5 @@ AUX nose-1.3.7-python-3.5-backport.patch 1802 BLAKE2B 8513cd506f7031ec4af1a4acd6
AUX nose-1.3.7-python-3.6-test.patch 3289 BLAKE2B 4f19c4f6e4f376cb09896f9e7b054753c339ad371e151f01cc8c54e83ecffee72e4959d827a88d03b4944192b43085b50017ef8b8785222125ce32fac5831717 SHA512 0be6e49f08a4098b4c5dd1d9678e757c8f1f317fb13bd355a035c44bcdd9cd043be1755bb97c4ca78397985f07f6fc486ddd10cb56dd8d8774d631eebcc81127
DIST nose-1.3.7.tar.gz 280488 BLAKE2B 4bb479b2786f813f9e9a5fd401e30023a473a053ae013d7887be15af415422c09fb399af6058ae99ed65c5fa4da84eb274eb805e895ca74db159d952905f5be4 SHA512 e65c914f621f8da06b9ab11a0ff2763d6e29b82ce2aaed56da0e3773dc899d9deb1f20015789d44c65a5dad7214520f5b659b3f8d7695fb207ad3f78e5cf1b62
EBUILD nose-1.3.7-r7.ebuild 2304 BLAKE2B 97be9d38b82206abc2e04d470f00ac21a6889c632b307e7b6c767c832742843c38cf2f949b5165369a69f222ded243e728ce93cbc044a42a2fcc3026ae01705c SHA512 4382b2a894c356eb311d253d2a49d697d94f623b2695242dfd6d1d07c38a204105de03518cbb461b08ef53d233552a015e17eedbb9ca9b16e14ca3cd110548c5
+EBUILD nose-1.3.7-r8.ebuild 2251 BLAKE2B 8efe621b30a90319cac473346b4776e99b8152e6b86ee7d4cc4aeb410225b7cfff3deaf7f8095966cc3bef97b100604c8ea8f295c6e805ab301a889ae21d29d7 SHA512 a559bea7bbfe88dfd7f3eed8a48bda5f2fbd198a59c0592c9168f34b078cd4462ea7139f2b22eff71fe0ffc7a9903f8d0492f8e548e8b77bfd2368f1ad0746f4
MISC metadata.xml 524 BLAKE2B 90a98bae0d27a49c51aee677f8bdebcbee461d74fad0f349f73458229098ba3038705d63a88c59f90ef8621931e5d3902c0209bd627c28d2b0296deaff4af75d SHA512 4dc9346469b9b3a0b87fffe49db530107a019bd798fba0620b671d71a43805537face8451c24d6ad40bf11ed3498d8970ddc1ce3109398534c9f3c8ed72743e0
diff --git a/dev-python/nose/nose-1.3.7-r8.ebuild b/dev-python/nose/nose-1.3.7-r8.ebuild
new file mode 100644
index 000000000000..9ff8d8ae5d04
--- /dev/null
+++ b/dev-python/nose/nose-1.3.7-r8.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+ https://pypi.org/project/nose/
+ https://nose.readthedocs.io/en/latest/
+ https://github.com/nose-devs/nose"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
+ ' python3_{7..9} pypy3)
+ $(python_gen_cond_dep '
+ dev-python/twisted[${PYTHON_USEDEP}]
+ ' python3_{7..9})
+ )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-python-3.5-backport.patch
+
+ # Patch against master found in an upstream PR, backported:
+ # https://github.com/nose-devs/nose/pull/1004
+ "${FILESDIR}"/${P}-coverage-4.1-support.patch
+
+ "${FILESDIR}"/${P}-python-3.6-test.patch
+)
+
+python_prepare_all() {
+ # Tests need to be converted, and they don't respect BUILD_DIR.
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+
+ # Disable tests requiring network connection.
+ sed \
+ -e "s/test_resolve/_&/g" \
+ -e "s/test_raises_bad_return/_&/g" \
+ -e "s/test_raises_twisted_error/_&/g" \
+ -i unit_tests/test_twisted.py || die "sed failed"
+ # Disable versioning of nosetests script to avoid collision with
+ # versioning performed by the eclass.
+ sed -e "/'nosetests%s = nose:run_exit' % py_vers_tag,/d" \
+ -i setup.py || die "sed2 failed"
+
+ # fix manpage install path
+ sed -i -e 's:man/:share/&:' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ local add_targets=()
+
+ if use test; then
+ add_targets+=( egg_info )
+ python_is_python3 && add_targets+=( build_tests )
+ fi
+
+ distutils-r1_python_compile "${add_targets[@]}"
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py -v || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}