summaryrefslogtreecommitdiff
path: root/dev-python/nose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 15:55:57 +0100
commit533ce9c954925ca2a6bccd1f52f266e81e61a678 (patch)
treeef0ef849f69e60394f4bbbab166e6b83848f609c /dev-python/nose
parent9a8514e070a40648dbc8e28ad6457d925542b79a (diff)
gentoo auto-resync : 26:10:2022 - 15:55:57
Diffstat (limited to 'dev-python/nose')
-rw-r--r--dev-python/nose/Manifest2
-rw-r--r--dev-python/nose/nose-1.3.7_p20221026.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/nose/Manifest b/dev-python/nose/Manifest
index 68d4a7fb045a..d7a7e1417648 100644
--- a/dev-python/nose/Manifest
+++ b/dev-python/nose/Manifest
@@ -1,3 +1,5 @@
DIST nose-1.3.7_p20211111_p1.gh.tar.gz 327855 BLAKE2B acddcaa0718f23f281ea34a977354b3ef88c95d4ef712afd8354effe6df7883d473b50caaa3b5c79fcc4c36a9d45bee4eb5865a6ef66e371dae12ed1a0a0418a SHA512 752eb1337fd481a1b8498ead330d716cf4180c18faabde257e9a1139928b9fa38e2e145d36c1ea8e3867a36d4843134ee26e9e9f83ff84d21f0fe246d2392d15
+DIST nose-1.3.7_p20221026.gh.tar.gz 325421 BLAKE2B 3762e1703a6a9c90d1569d21efa9ba100f52a8b3660022694133a763d995e19a6eef2398f5013b4827e4c334a2d5e3cd14a9704a50cd822c2d554a0ed6008f2c SHA512 3cb97b58525bee0cf88328ba865dc039bf3b76c56b4b42dd9dcf68f7b7585a91fb7e9b0c419668eccc0e242b2bcbb77eb197a0954ee9ad50051ef3af1a81dac3
EBUILD nose-1.3.7_p20211111_p1-r1.ebuild 1485 BLAKE2B 277e62799964afef8e41b237d2642170568c5f8f333ea9395fc90147c86dd6390a3abb1e442358f619c4637673b7738ad7079f78aa423530e5729f5468a6f854 SHA512 6687bc5e75b2899ade13a066cc60819070ea2cdf692f2da46661dd42f6282eb2cbf543f773df50aa208dcbf88f5916edf83e4fd28b6cf53a01c6d78dde0c8129
+EBUILD nose-1.3.7_p20221026.ebuild 1493 BLAKE2B bc37ccc8d1c7bcc4dcf43569aa2915069a91f2e57805c4430a585f333fc3fc5af8d28800945b7b831f67e56da80503acf374e8297623742e4a9c261397bf75fb SHA512 63892324788ee3b34b5a112fa800eb600ac7a44292f0efdc299774c295073172ff27567027de3ccaf9adf2f97fc9ec5d27889b32700b72adfabb59195470aaf8
MISC metadata.xml 399 BLAKE2B bccd250e005dc4b4921b8affffa56c918069576663c44671189d40dea344c0fb880fcf41656b1c9c5043cea9a0203b3ad3b980f7920ecebab82b4c71f75214d4 SHA512 15fd9ea9d0c09833f25497e2715a15cb2b2dbcbe042e0a3fa24525455eaeb470d6c799fddcd635a5197c984252649a26352713fcd069123fe2546edc20566fa6
diff --git a/dev-python/nose/nose-1.3.7_p20221026.ebuild b/dev-python/nose/nose-1.3.7_p20221026.ebuild
new file mode 100644
index 000000000000..83b354dadcd7
--- /dev/null
+++ b/dev-python/nose/nose-1.3.7_p20221026.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+EGIT_COMMIT="8def1b4dcf2ef6b4a34bffdfacea0018a78b06b6"
+DESCRIPTION="Unittest extension with automatic test suite discovery and easy test authoring"
+HOMEPAGE="
+ https://pypi.org/project/nose/
+ https://nose.readthedocs.io/en/latest/
+ https://github.com/nose-devs/nose
+"
+SRC_URI="
+ https://github.com/arthurzam/nose/archive/${EGIT_COMMIT}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/${PN}-${EGIT_COMMIT}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ $(python_gen_cond_dep '
+ !hppa? ( dev-python/coverage[${PYTHON_USEDEP}] )
+ ' python3_{8..10} pypy3)
+ $(python_gen_cond_dep '
+ dev-python/twisted[${PYTHON_USEDEP}]
+ ' python3_{8..10})
+ )
+"
+
+src_prepare() {
+ # failing to find configuration file
+ sed -e 's/test_cover_options_config_file/_&/' \
+ -i unit_tests/test_cover_plugin.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" -m nose -v -a "!network" ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+src_install() {
+ distutils-r1_src_install
+ use examples && dodoc -r examples
+}